Fordmods Logo

umm.... is this normal?? HELP!!! 

 

Page 2 of 3 [ 32 posts ] Go to page Previous  1, 2, 3  Next

 
Posted: Mon May 09, 2005 7:30 pm 
Technical Contributor
Offline
User avatar

Age: 33

Posts: 5858

Joined: 5th Nov 2004

Gallery: 8 images

Ride: '95 EF's

Location: Leederville
WA, Australia

lol woah - actually looked at the pic now! looks to me like a CPI EA :?

 

_________________

R.I.P. Scotty

Top
 Profile  
 
 
Posted: Mon May 09, 2005 7:32 pm 
Oompa Loompa
Offline

Age: 32

Posts: 22

Joined: 7th May 2005

Location: Adelaide
SA, Australia

its a 1991 EA........................

edit: 1990???

meh, can't remember... LOL!!

edit edit:

the engine...

Image

edit edit edit: 1991 :)

30th anniversary edition... :p
Top
 Profile  
 
 
Posted: Mon May 09, 2005 7:53 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2282

Joined: 14th Jan 2005

Gallery: 8 images

Ride: ED Fairmont Ghia & EF XR8

Location: Melbourne
VIC, Australia

yes it is a centre point engine, your best bet is to go to a wrecker and get a new intake, or just make your own

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon May 09, 2005 7:55 pm 
Oompa Loompa
Offline

Age: 32

Posts: 22

Joined: 7th May 2005

Location: Adelaide
SA, Australia

how does the existing thing come off?? it looks like its part of the radiator mount, or something... :?
Top
 Profile  
 
 
Posted: Mon May 09, 2005 9:58 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2282

Joined: 14th Jan 2005

Gallery: 8 images

Ride: ED Fairmont Ghia & EF XR8

Location: Melbourne
VIC, Australia

AmmoJammo wrote:
how does the existing thing come off?? it looks like its part of the radiator mount, or something... :?


yeh your right it looks as though it part of the radiator shroud, even still this is easily rmoved should cost you bout 20 - 30 at a wreckers.

why not just patch up the hole in the exiting piping and scrape out all the silicone with a screw driver or something. in the end it up to you

 

_________________

Image

Top
 Profile  
 
 
Posted: Tue May 10, 2005 1:29 pm 
Oompa Loompa
Offline

Age: 32

Posts: 22

Joined: 7th May 2005

Location: Adelaide
SA, Australia

nannas_ed wrote:

why not just patch up the hole in the exiting piping and scrape out all the silicone with a screw driver or something. in the end it up to you


the silicon is about 2cm thick, and has been in there for YEARS!!! its stuck... :p I was going to attact it with a knife... thats this afternoons project :)
Top
 Profile  
 
 
Posted: Tue May 10, 2005 2:04 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

Yeah quick fix cut out all the silicon you can, grab something the siz of the hole at the botton thats pretty solid and tape it around with duct tape to hold it there, and see how the performance is, replace the part soon.

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
Posted: Tue May 10, 2005 10:52 pm 
Getting Side Ways
Offline
User avatar

Age: 52

Posts: 4370

Joined: 5th Nov 2004

Ride: BA Fairlane Ghia

Location: Karratha
WA, Australia

Maybe someone had a pipe running off it, under the bumper etc, for cold air???
Top
 Profile  
 
 
Posted: Tue May 10, 2005 10:56 pm 
Getting Side Ways
Offline

Posts: 4967

Joined: 22nd Nov 2004

Location: FAR FAR AWAY LAND
QLD, Australia

maybe chunkz had been playing with it

 

_________________

Image

Top
 Profile  
 
 
Posted: Tue May 10, 2005 11:17 pm 
Getting Side Ways
Offline
User avatar

Age: 52

Posts: 4370

Joined: 5th Nov 2004

Ride: BA Fairlane Ghia

Location: Karratha
WA, Australia

noisuf wrote:
maybe chunkz had been playing with it

Hahahahahaha, LOL, on ya noisuf.
Top
 Profile  
 
 
Posted: Tue May 10, 2005 11:19 pm 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 10126

Joined: 5th Nov 2004

Gallery: 4 images

Ride: EF Gli Ghia, XP Fairmont

Location: Perth
WA, Australia

AmmoJammo wrote:
well... you seem like a smart bunch....

why the F**k would anyone do this?

Image

basically, it meant the engine was drawing air in straight across one of the radiator hoses.... that means... 60+ degree air going into the engine... :roll: (at a guess)

pure stupidity :!: :?

 

_________________

Owning 1 of 67612 EF GLi Sedans made
FACT: "Chuck Norris owns the greatest Poker Face of all-time. It helped him win the 1983 World Series of Poker despite him holding just a Joker, a Get out of Jail Free Monopoly card, a 2 of clubs, 7 of spades and a green #4 card from the game Uno."

Top
 Profile  
 
 
Posted: Wed May 11, 2005 3:40 pm 
Oompa Loompa
Offline

Age: 32

Posts: 22

Joined: 7th May 2005

Location: Adelaide
SA, Australia

bowsaw wrote:
Maybe someone had a pipe running off it, under the bumper etc, for cold air???


umm... considering the radiator hose covered half the hole.... I don't think so.. :p

plus... a rectangle shaped pipe? lol

also, I'd like to know why noone else commented on it. :roll:
Top
 Profile  
 
 
Posted: Wed May 11, 2005 6:13 pm 
Tyre Shredder
Offline
User avatar

Age: 32

Posts: 320

Joined: 19th Nov 2004

Gallery: 3 images

Ride: AU-XR8

Location: Sth Syd
NSW, Australia

Not surprising,

A guy at my old school rigged up his intake piping behind the radiator & fan so "the fan could force cold air into the motor like a turbo".

Interesting how some people think :?

 

_________________

She'd be a lot more modded if I didn't have to keep wasting cash on repairs.

Top
 Profile  
 
 
Posted: Wed May 11, 2005 7:03 pm 
Oompa Loompa
Offline

Age: 32

Posts: 22

Joined: 7th May 2005

Location: Adelaide
SA, Australia

yeah, but the previous owner of this car was mid 30's

before that, I believe it was used by a company for something... :?
Top
 Profile  
 
 
Posted: Thu May 12, 2005 11:43 am 
Tyre Shredder
Offline
User avatar

Age: 32

Posts: 320

Joined: 19th Nov 2004

Gallery: 3 images

Ride: AU-XR8

Location: Sth Syd
NSW, Australia

AmmoJammo wrote:

before that, I believe it was used by a company for something... :?



Hopefully it wasnt a development mule for a performance company.

If so, it looks like they were heading in the wrong direction.

 

_________________

She'd be a lot more modded if I didn't have to keep wasting cash on repairs.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 3  [ 32 posts ]  Go to page Previous  1, 2, 3  Next

Who is online

Users browsing this forum: Google [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 7:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names