Fordmods Logo

Upgrading dushboard cluster 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Upgrading dushboard cluster
Posted: Tue Aug 09, 2005 5:08 pm 
Oompa Loompa
Offline

Age: 37

Posts: 25

Joined: 23rd Dec 2004

Ride: falcon ed svo

Location: geelong
VIC, Australia

Hi everyone!

I have a question and hopefully somebody could give me an advice.
I have falcon ED and yesterday i've changed original dushboard basic speedo with two gauges (temperature and fuel) for sports pack cluster which have tacho, speedo + two additional gauges (battery and oil). In wreckers a guy told me that I will have to run an additional wire for tacho plus I'll have to change an oil switch to one which is compitable with this cluster. I changed those clusters and nearly everything was working straight away, even tacho! The guy was right about the oil switch though..
Now the oil gauge goes right up to the max with this oil switch. But there is something else that Im warried about. When I start the engine light comes up and it shows some container with fan in the middle. I guess it's got to do something with the temperature. But the car works perfectly normal and it doesnt overheat. Do you have any ideas what is this? Maybe it is another incompitability like the oil switch for base models?

 

_________________

This registration could be more simple mate, just a friendly sugestion!

Top
 Profile  
 
 
Posted: Tue Aug 09, 2005 5:11 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2550

Joined: 28th Jun 2005

Gallery: 13 images

Ride: EF 5 Speed, XH Uterus :P

Location: Hobart
TAS, Australia

sounds like the low coolant level warning light in the ef/el's. have you checked coolant level??

 

_________________

Maloo - Holden's word for ugly.

Top
 Profile  
 
 
Posted: Tue Aug 09, 2005 5:16 pm 
Oompa Loompa
Offline

Age: 37

Posts: 25

Joined: 23rd Dec 2004

Ride: falcon ed svo

Location: geelong
VIC, Australia

Yes, it is nearly to the max. Doesnt use any coolant since head gasket was changed.

 

_________________

This registration could be more simple mate, just a friendly sugestion!

Top
 Profile  
 
 
Posted: Tue Aug 09, 2005 5:25 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2550

Joined: 28th Jun 2005

Gallery: 13 images

Ride: EF 5 Speed, XH Uterus :P

Location: Hobart
TAS, Australia

sounds like the coolant sensor's gone dead, if that's what the light is. i'm presuming that the sensor wiring is the same for both dash's, if not there's the problem there.

 

_________________

Maloo - Holden's word for ugly.

Top
 Profile  
 
 
Posted: Tue Aug 09, 2005 6:42 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 1294

Joined: 6th Nov 2004

Gallery: 7 images

Ride: 80 series cruiser

Location: sydney
NSW, Australia

more than likely, your car doesnt have the low coolent sensor in the plastic header tank, bubble topped looking thingie, all i did was remove the bulb in the dash, problem fixed, lol. the proper way is to get a header tank with the switch in it and there will be a plug in the loom near it in the engine bay, just plug her in and your done.

 

_________________

Thanks to Crescent Motors, Liverpool.
Call Joe on (02) 9600 6229.

I dont own a Landcruiser, it's a Maverick recovery vehicle!!!!

Top
 Profile  
 
 
Posted: Tue Aug 09, 2005 6:55 pm 
Oompa Loompa
Offline

Age: 37

Posts: 25

Joined: 23rd Dec 2004

Ride: falcon ed svo

Location: geelong
VIC, Australia

Yea you might be right.. Im gonna get the new oil switch and I'll try to find this tank with sensor, if not well light bulb will go out.

Thanks guys!!

 

_________________

This registration could be more simple mate, just a friendly sugestion!

Top
 Profile  
 
 
Posted: Tue Aug 09, 2005 8:13 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Have a read of the doco http://www.fordmods.com/forums/documents.php?doc=45 if you haven't already.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Take Note
Posted: Tue Aug 09, 2005 9:29 pm 
Getting Side Ways
Offline

Posts: 476

Joined: 28th Jan 2005

Ride: 1990 EA Spac

Location: grenfell
NSW, Australia

Do not take the globe out of the cluster. Do the right thing and go to the wrecker and get a header tank with the sender.

It might just save your engine as it gives you warning of low coolant way befor the temp gauge. It also will show up the warning if the circuit goes open circuit or short circuit. So if the light comes on and the water level is ok then the circuit is at fault and you can find the fault. It protects your engine so dont take the easy out please. I know because my sone cooked his engine because by the time the temp gauge registered all the water had gone.

cheers

 

_________________

Drive safe, arrive alive

EA Spak EL dash and interior, thermo's,BBM, EF head and cam, superlows,

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 6:33 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names