Fordmods Logo

Upper cylinder lube kit Ie flashlube 


Page 1 of 1 [ 5 posts ] 

 Post subject: Upper cylinder lube kit Ie flashlube
Posted: Tue Dec 06, 2005 10:21 pm 
Fordmods Newbie

Posts: 5

Joined: 15th Nov 2005

Location: warrnambool
VIC, Australia

Has anyone fitted one of those upper lube kits.
My AU series 1 4ltr is on gas and I am thinking of fitting one,any opinion would be appreciated.......Tanks :?:
Posted: Tue Dec 06, 2005 10:32 pm 
Getting Side Ways
User avatar

Age: 30

Posts: 11101

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

Don't bother. Next time you hope in a taxi ask him if hes running on LPG and have a squize at the odometer. Most are on like 700,000 and don't run an upper lube kit, if they can do that sorta milage without them there should be no reason you need one. Aside from tyhat I think there more aimed at old cars.



Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Posted: Wed Dec 07, 2005 12:00 am 
Getting Side Ways

Age: 35

Posts: 9453

Joined: 9th Nov 2004

Gallery: 4 images

Ride: Fordrunner 5.0 Turbo

Location: Wollongong
NSW, Australia

Yep. Old cars with cast iron heads and soft valve seats need them new cars dont. On my old LRP XF I never even bothered with flashlube and it still went alright.
Posted: Wed Dec 07, 2005 9:59 am 
Fordmods Junkie
User avatar

Age: 37

Posts: 1000463

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

depends on the head
if it is dedicated au gas no u dont need it ( green rocker cover )

if it is dual fuel i would suggest it but does depend on the the valve seats




Posted: Wed Dec 07, 2005 12:40 pm 
Getting Side Ways

Posts: 988

Joined: 4th Dec 2004

Ride: el faimont, dual fuel

Location: melbourne
VIC, Australia

needed once you rack some serious k's, normal car around 500,000k's taxis around 750,000k's.

the au stopped starting on gas and ran rough at about the 700 mark so dad banged one these kits on, with penrite lube, and next day start her up head starts rattling very bad so we turn it off and on again runs smooth as and starts on gas again.



why do u write in here.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Chimei and 19 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 10:24 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names