Fordmods Logo

Vent Issue ! 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Vent Issue !
Posted: Thu Feb 04, 2010 7:31 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Hey guys i am having an issue with my EB II and that issue is that i am constantly having air blow out my face vents and it is quite annoying. One vaccum hose is on the heater tap and the other one is on the manifold and i didnt touch anything (so this problem just popped up). It seems like the switch that either allows fresh air in or makes it recirculate is disconnected but i dont now know where this hose/switch is too look at it !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: Vent Issue !
Posted: Thu Feb 04, 2010 8:05 pm 
Tyre Shredder
Offline

Age: 25

Posts: 359

Joined: 22nd Dec 2009

Gallery: 10 images

Ride: el xr6, r33 series 2 skyline

Power: 149 rwkw

Location: adelaide
SA, Australia

i dunno if its anything like my el

but i took my whole dash out and i had to disconect the arcon unit and there were many diffrent hoses at the back some of them with suction, posibly check out the back of your arcon unit n see if any hoses are out of possition

 

_________________

God made s**t, Holden put wheels on it

skyline daily
ford building

Top
 Profile  
 
 
 Post subject: Re: Vent Issue !
Posted: Thu Feb 04, 2010 10:39 pm 
Stock as a Rock
Offline

Age: 32

Posts: 186

Joined: 5th Nov 2004

Gallery: 1 images

Ride: 1997 EL Fairmont,2008 FG G6E

Location: Melbourne
VIC, Australia

I would say that your fresh/recirc air vent is broken. It's kind of a common problem with these cars best way to check is on the LHS under the glove box u will see the flap if you can move it with your hand without any effort then it's broken. It's a simple repair on a EA/ED just remove the glove box surround and 3 nuts holding it in place.
Top
 Profile  
 
 
 Post subject: Re: Vent Issue !
Posted: Mon Feb 08, 2010 12:33 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Took the surround off and the only thing i could find is the heater/aircon temp switch thing it would move with a bit of effort. But i couldnt find the flap you are talking about, do you have any pictures of it ?

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: Vent Issue !
Posted: Tue Feb 09, 2010 11:45 am 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

anyone?

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 12:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names