Fordmods Logo

Voltage Dramas!!! 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Voltage Dramas!!!
Posted: Wed May 14, 2008 3:50 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 423

Joined: 17th May 2007

Being the turkey that I am, after buying a new battery I hooked up the + to the - and - to the +, my mind was in dreamland, lol. The car had a fit and blew the ignition fuse, I put the terminals right and fixed the fuse, but now when the cars running the voltmeter gauge shows the orange warning light constantly, meaning there is an issue with the electrical system of some sort. The gauge shows one notch under midway which I think is lower than normal. The car's an EF Mont. Any ideas what the prob. could be?
Top
 Profile  
 
 
Posted: Wed May 14, 2008 5:11 pm 
Stock as a Rock
Offline

Age: 35

Posts: 187

Joined: 30th Dec 2006

Ride: 95 EF I

Location: Melbourne
VIC, Australia

blown regulator or diodes in the alternator? wouldnt run it til an auto elec has looked at it mate, could fck the new battery if not more...
Top
 Profile  
 
 
Posted: Wed May 14, 2008 5:13 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4849

Joined: 19th Feb 2005

Gallery: 1 images

Ride: BA Falcon Suzy Across

Power: 178 rwkw

Location: melbourne
VIC, Australia

if you have the wiring diagram for the car such as in a gregories, see what will trigger the warning light to cut down the list of potential problems, then makes sure they all work properly. If the warning light only activates if the voltage is too low, test the battery yourself with an external tester to work out if the battery is stuffed or the voltmeter is stuffed.

 

_________________

178.3 rwkw
15.1@96 mph
Now with 3.9 shrooms

Top
 Profile  
 
 
Posted: Wed May 14, 2008 6:11 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 423

Joined: 17th May 2007

zxhoon wrote:
blown regulator or diodes in the alternator? wouldnt run it til an auto elec has looked at it mate, could fck the new battery if not more...


If there is anything wrong with the alternator, the alternator warning light would flash up on the dash? I should mention the car drained a brand new $170 Bosh battery in 2 days just sitting under the carport. I found the glove box light would not turn off so I took that out it had been on the whole time, could have been the cause? The radio doesn't work now either, lol, I got a proper battery charger onto the battery though and it's nice and strong again. It's been in the car for over a day and is still charged. Bloody electrics, intense stuff..I'll have a gander at the Gregory's manual but my electrical skills are sh!thouse.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names