Fordmods Logo

weak spark/coil failure on ea 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: weak spark/coil failure on ea
Posted: Wed Jan 14, 2009 10:18 pm 
Getting Side Ways
Offline
User avatar

Posts: 807

Joined: 28th Oct 2008

Location: melburn
VIC, Australia

ok so after replacing a few things with s**t from a wrecker to keep cost down, i figured out i was getting no spark in my EA due to a f**k dizzy

so i had good spark for a minute or two...(car didnt start as timing was out)
then it became weak spark
so i hooked up my old coil as a chance that it wasnt faulty - which it wasnt
so i had strong spark again! yay!

then it became weak again...

soo i figured that both coils could have just been cactus as they were both pretty sad lookng
but before i buy a brand new coil, is there something that can cause the coil to fail?
TFI? s**t dizzy?

ive heard that testing the coil with a lead straight from the coil to well...no where can fry them, but spark is going through to the leads

just dont wanna have buy a new coil, bring it home and have the same thing happen lol

any help would be good :)

 

_________________

XG Panelvan
mild engine, EL ECU & J3, HI6 & MSD coil

in the shed - .595" lift cam, GT4202, forged AU engine, ems 4424 ecu, glide & 5500 stall - next-bellhousing

XH ute daily - DOHC BA XR6 engine, T5, AU3 ECU, J3 chip, wideband & logger, ported BBM, 3" intake

Top
 Profile  
 
 
Posted: Wed Jan 14, 2009 10:25 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

what condition is the dizzy cap rotor and leads in?? but i would say more than likely the tfi module would be stuffed...
Top
 Profile  
 
 
Posted: Wed Jan 14, 2009 10:30 pm 
Getting Side Ways
Offline
User avatar

Posts: 807

Joined: 28th Oct 2008

Location: melburn
VIC, Australia

well the spark i was testing was from the coil, not the dizzy - so doesnt have anything to do with the cap and rotor

and i thought the TFI module only controlled when the coil fired, not how strong it fired?

 

_________________

XG Panelvan
mild engine, EL ECU & J3, HI6 & MSD coil

in the shed - .595" lift cam, GT4202, forged AU engine, ems 4424 ecu, glide & 5500 stall - next-bellhousing

XH ute daily - DOHC BA XR6 engine, T5, AU3 ECU, J3 chip, wideband & logger, ported BBM, 3" intake

Top
 Profile  
 
 
 Post subject: Re: weak spark/coil failure on ea
Posted: Wed Jan 14, 2009 11:09 pm 
Parts Gopher
Offline

Posts: 72

Joined: 13th Mar 2007

Location: Melbourne
VIC, Australia

[quote="misk_one"]
ive heard that testing the coil with a lead straight from the coil to well...no where can fry them, but spark is going through to the leads

Yes, running a coil open circuit like that will kill it.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 12:07 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names