Fordmods Logo

Weird Error(dash) 

 

Page 1 of 2 [ 20 posts ] Go to page 1, 2  Next

 
 Post subject: Weird Error(dash)
Posted: Mon Jan 22, 2007 10:06 pm 
Oompa Loompa
Offline

Age: 29

Posts: 28

Joined: 29th Nov 2006

Ride: 1994 ED Futura

Location: Tamworth
NSW, Australia

First off, I did search and I got this.

Search found 5913 matches

This is in an auto ED Futura...

So... I'm reversing up a hill to get into my garage right, when all of a sudden the car starts clunking and on the dash I see this red light that looks abit like a Battery with a Fan in the middle of it, it made absolutely no sense to me whatsoever, but then I noticed that the coolant level was low, I bought some coolant, topped her up and she ran good for about another 100m with no error lights and then the same thing happened.

I also noticed that after the error light came up, it now idles at under 1000 which is rediculously low.

So I'm wondering, what does this error light mean? I'm presuming it's a pretty common thing and can be solved quite easily since it has its own error light.

Thanks.

 

_________________

1994 ED Futura
15" Alloys
Kenwood Deck
15" JVC Sub
6" Fusion Splits

Top
 Profile  
 
 
Posted: Mon Jan 22, 2007 10:12 pm 
Getting Side Ways
Offline

Age: 29

Posts: 573

Joined: 5th Jun 2005

Ride: BA XR6 Turbo

Power: 221 rwkw

Location: A
ACT, Australia

It sounds like your coolant light is coming on, and by the sounds of it you are loosing coolant FAST!!! Can you see if it is leaking any were on the ground and if so where abouts??? I dont understand why it would be clunking in reverse, what kinda clunking and where is the clunking coming from???
Also your car should idal at 700rpm, so its normal to be under 1000rpm

Griffo

 

_________________

ED XR6 manual for sale. MOMO steering wheel and alot of extra's. PM for more info.


BA XR6 Turbo- 238.8rwkw

Top
 Profile  
 
 
Posted: Mon Jan 22, 2007 10:29 pm 
Oompa Loompa
Offline

Age: 29

Posts: 28

Joined: 29th Nov 2006

Ride: 1994 ED Futura

Location: Tamworth
NSW, Australia

Thanks mate, I think I'll check again in the morning for any spots of coolant under the engine also, I'll check in the engine to see if theres any there.

 

_________________

1994 ED Futura
15" Alloys
Kenwood Deck
15" JVC Sub
6" Fusion Splits

Top
 Profile  
 
 
Posted: Mon Jan 22, 2007 10:45 pm 
Stock as a Rock
Offline
User avatar

Age: 42

Posts: 171

Joined: 28th Nov 2006

Gallery: 2 images

Ride: AU series 2 ute

Location: Dalby
QLD, Australia

riggaz wrote:
Thanks mate, I think I'll check again in the morning for any spots of coolant under the engine also, I'll check in the engine to see if theres any there.
try checking your dip stick for signs of water ie: milky looking oil.

 

_________________

Holden's are a phase you go through then you grow some nuts and buy a FORD!!!!!!![/u]

Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 8:16 am 
Oompa Loompa
Offline

Age: 29

Posts: 28

Joined: 29th Nov 2006

Ride: 1994 ED Futura

Location: Tamworth
NSW, Australia

Oil isnt milky i'm pretty sure its the coolant, its not leaking but its just disappearing.

anyone know where i can find out what all the lights on the dash mean?

 

_________________

1994 ED Futura
15" Alloys
Kenwood Deck
15" JVC Sub
6" Fusion Splits

Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 8:35 am 
Getting Side Ways
Offline

Age: 38

Posts: 1320

Joined: 5th Nov 2004

Ride: 66 Coupe

Location: Perth
WA, Australia

owners manual would be a good place to start?
Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 9:22 am 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

mine clunks in reverse sometimes and sometime when i take off, but the bushes are nakered in the back, been to slack to change them
Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 9:46 am 
Oompa Loompa
Offline

Age: 29

Posts: 28

Joined: 29th Nov 2006

Ride: 1994 ED Futura

Location: Tamworth
NSW, Australia

66 coupe wrote:
owners manual would be a good place to start?


sorry i failed to mention i dont have one.

Also, mine also clunks in reverse and when im accelerating from a stand still... wtf are these 'bushes' though? that sounds about right and how much is it to fix them?

 

_________________

1994 ED Futura
15" Alloys
Kenwood Deck
15" JVC Sub
6" Fusion Splits

Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 10:14 am 
Getting Side Ways
Offline
User avatar

Age: 26

Posts: 1028

Joined: 13th Jul 2006

Gallery: 6 images

Ride: Falcon

Location: Sydney
NSW, Australia

Have you checked your oil? If the coolant is just "disappearing", check the oil, because it could be disappearing into your oil. If it is milky, or bubly, or doesn't look like honey, chances are you have blown the head gasket.

On an ED Futura, you would have:
    -Low volts - battery icon
    -Low oil press - oil filler icon
    -high engine temp - temp icon
    -low fuel level - bowser icon
    -low coolant level - fan in a box (radiator) icon
    -park brake
    -smartlock
    -Auto trans power indicator
    -brake fail lamp ((!))


And so on, check here: http://www.fordmods.com/forums/documents.php?doc=45

To make sure.
Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 10:27 am 
Getting Side Ways
Offline

Age: 36

Posts: 3794

Joined: 9th Aug 2005

Ride: Hilux

Location: Mornington
VIC, Australia

as has been covered many times but you tried searching so i will try to forgive you the light is indeed for your low coolant sensor.

it cant just :dissapeer" as you say, it has to go somewhere. unfortunatly a likely candidate is thehead gasket. though if you are lucky it may just be a split hose or welsh plug.

best bet to have it running, full of water and just look and watch to see if you can see where it is actually going.

 

_________________

Now driving a Hilux

Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 10:57 am 
Oompa Loompa
Offline

Age: 29

Posts: 28

Joined: 29th Nov 2006

Ride: 1994 ED Futura

Location: Tamworth
NSW, Australia

I know its not the oil or whatever, I checked that and the oil is fine, both the level and color

and its def the coolant level indicator... I'll get some more coolant today because i have a feeling that the coolant was just low so ill get a fair bit today and fill her up to the max then leave it running and see if the coolant just goes away.

Thanks for the help i'll update you guys tonight.

 

_________________

1994 ED Futura
15" Alloys
Kenwood Deck
15" JVC Sub
6" Fusion Splits

Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 4:46 pm 
Stock as a Rock
Offline

Age: 35

Posts: 119

Joined: 1st Feb 2006

Ride: 95 NF Fairlane

Location: melbourne
VIC, Australia

the rubbers you are in need of are the rear upper and lower control arm bushes .. they are cheaper and easier to get "reco'd"i think every ford i have had has been in great need of them .. also yes it could be there head gasket but just leaking inbetween the cylinder and water jacket .. if you fill the radiator right up and the have the car running and the water is bubbling and decreasing then it can be a sign that the head gasket is gone .. it doesnt mean that the oil colour will change just that its going through it to the cylinder instead .. eb ed should idle @ 650 - 700 so as griffo161 said its normal .. its when its under 600 that it becomes a concern ... cheers hope that this helps mate

 

_________________

93 EB 4 Speed auto , 2 1/2 sports from cat back , pod filter , LSD , super low suspenstion , mok tickford rims 15" , 7 colour changing led parker lights , led no plate lights and still want more .. allooootttttttttttt more ..

"Drive it , Like you stole it " ... so whats your excuse :D

Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 11:43 pm 
Oompa Loompa
Offline

Age: 29

Posts: 28

Joined: 29th Nov 2006

Ride: 1994 ED Futura

Location: Tamworth
NSW, Australia

kaiden351 wrote:
the rubbers you are in need of are the rear upper and lower control arm bushes .. they are cheaper and easier to get "reco'd"i think every ford i have had has been in great need of them .. also yes it could be there head gasket but just leaking inbetween the cylinder and water jacket .. if you fill the radiator right up and the have the car running and the water is bubbling and decreasing then it can be a sign that the head gasket is gone .. it doesnt mean that the oil colour will change just that its going through it to the cylinder instead .. eb ed should idle @ 650 - 700 so as griffo161 said its normal .. its when its under 600 that it becomes a concern ... cheers hope that this helps mate


Yeah it's now idleing low enough to be on the brink of stalling, this is an automatic btw.

How much is it to get a mechanic to fix the bushes?

Btw it's not the coolant...

 

_________________

1994 ED Futura
15" Alloys
Kenwood Deck
15" JVC Sub
6" Fusion Splits

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 9:03 am 
Stock as a Rock
Offline

Age: 35

Posts: 119

Joined: 1st Feb 2006

Ride: 95 NF Fairlane

Location: melbourne
VIC, Australia

wow .. ok ..the arms are about 200 250 the set ... this is for 4 reco'd arms with new rubbers in them .. it will cost around the same just for the rubbers and to have them pressed in ... sadly there are all pressed in .. :( i hate that idea .. but i am going off melb price .. it could be more or less in nsw ... not to sure .. if i was you i would get the new arms as they have been checked and cleaned so u know that that are a good lot .. now as far as idle goes .. when you are driving .. is the motor smooth or does it feel like its missing .. ?? if it smooth but only low when you are at idle .. does it blow more condensation then before ... ??? i am hitting towoards head gasket like i said before but ill wait to see what you say ... what do you mean its not the coolant .. ??? , have you tried filling it up to see if it bubbles ??? and just so i have it right .. it is clunking from the rear correct .. ???
Quote:
Btw it's not the coolant...

 

_________________

93 EB 4 Speed auto , 2 1/2 sports from cat back , pod filter , LSD , super low suspenstion , mok tickford rims 15" , 7 colour changing led parker lights , led no plate lights and still want more .. allooootttttttttttt more ..

"Drive it , Like you stole it " ... so whats your excuse :D

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 3:07 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1421

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

riggaz wrote:
66 coupe wrote:
owners manual would be a good place to start?


sorry i failed to mention i dont have one.

Also, mine also clunks in reverse and when im accelerating from a stand still... wtf are these 'bushes' though? that sounds about right and how much is it to fix them?


it also could be stuffed universal joint(s) there about $40 to buy so id look at them first, and there easy to check aswell if they are stuffed

mine also goes "clunk" into reverse, then when you start to reverse it feels like you left your handbrake on then another "clunk" and she's away, and then it will "clunk into 'D' :?

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 20 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:11 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names