Fordmods Logo

Weird Idle Control Issues 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Weird Idle Control Issues
Posted: Thu Jan 03, 2013 3:45 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

The idle speed control valve suddenly stopped working a few days ago. Unplugging it had no effect, so it clearly wasn't working. I bought another one from the wreckers, installed it, and it worked fine.

Started the car again today, and the "new" ISC has the same problem. No change when you unplug it. I back-probed the terminals of the connector, and am getting full battery voltage on both. Does that mean that my "new" ISC has failed too? What are the chances of that?

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: Weird Idle Control Issues
Posted: Thu Jan 03, 2013 3:54 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

perhaps the ECU driver is stuffed, try another ecu.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: Weird Idle Control Issues
Posted: Thu Jan 03, 2013 3:58 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Thanks for that. If I'm getting full voltage to the ISC, doesn't that mean that the ECU driver is trying to open the valve, ie functioning properly? Thanks for the help.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: Weird Idle Control Issues
Posted: Thu Jan 03, 2013 4:09 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Nah, most if not all of the actuators/controllers get 12v on one side, and 12v the other if they're closed, not operating, etc. The ECU then controls one side by varying voltage - in the ISC's case, it may be a PWM signal, can't remember.
I think the Gregory's gave the respective outputs - the ECU pinouts in the Tech docs might give you some values as well.
+1 on Andrew's call on the blown driver.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: Weird Idle Control Issues
Posted: Thu Jan 03, 2013 4:16 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

the isc has constant 12v with ignition on, the controler is controled by pwm on the earth side..

the isc driver in your ecu might be crook??
Top
 Profile  
 
 
 Post subject: Re: Weird Idle Control Issues
Posted: Tue Jan 08, 2013 5:26 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Seems like it was the ISC driver in the ECU. I replaced the ECU and it's all good. Thanks for all the good advice - you guys are onto it.

I talked to my friendly Ford mechanic about it, and he says it's fairly common for the ISC to fail and push 12V back into the 5V ECU, which burns out the driver. So, if you replace the ECU without replacing the ISC, you will blow the new ECU again. The old ISC promptly went in the bin :)

Thanks again.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 3:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names