Fordmods Logo

weird stuttering when you push the throttle on petrol. 

 

Page 1 of 2 [ 20 posts ] Go to page 1, 2  Next

 
 Post subject: weird stuttering when you push the throttle on petrol.
Posted: Wed Aug 11, 2010 5:45 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

Hi all,

[Please see latest post for updated symptoms, I was wrong previously]

http://www.fordmods.com/post1171880.html#p1171880 <---- Latest post //-->

As per the subject, I have an EL falcon duel fuel... and it has a weird stutter down low when idling on petrol, on gas I have not noticed anything but it's pretty bad on petrol.... I have since put a new tank of bp ultimate with an injector cleaner in it.. but it has made no difference.. disconnected the battery to start the learning of the ECU again.. likewise no difference.

Once the revs go up a bit, the spluttering stops and it runs great.. it's just that 500rpm spot around the 1200-1800ish revs.

It has reasonably new (6 months old) TopGun 10mm leads (300 series I think they are called) I can't find any vacuum leaks and I'm looking for some ideas.

Any suggestions folks?

rgds

Frank

Last edited by frankieh on Sun Aug 15, 2010 8:22 pm, edited 3 times in total.

Top
 Profile  
 
 
 Post subject: Re: weird stuttering down low when idling on petrol.
Posted: Wed Aug 11, 2010 9:51 pm 
Stock as a Rock
Offline

Age: 33

Posts: 141

Joined: 17th Jun 2006

Ride: Falcon

Location: canberra
ACT, Australia

I'd clean the throttle body and Idle Speed control motor to start off with.

 

_________________

Fords Rule. OK.

Top
 Profile  
 
 
 Post subject: Re: weird stuttering down low when idling on petrol.
Posted: Wed Aug 11, 2010 10:31 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

lee lee le bonk wrote:
I'd clean the throttle body and Idle Speed control motor to start off with.



I wouldn't. a dirty TB and ISC won't effect anything at the RPM he's talking about.


First off, It seems to run fine on LPG, that would indicate the ignition system is not to blame.
That leaves the injection side of things.

How long has it been duel fuel?
How often do you run it on petrol?
How long since the injector have been removed and sonic cleaned?

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
 Post subject: Re: weird stuttering down low when idling on petrol.
Posted: Thu Aug 12, 2010 12:40 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

The car has been dual fuel for years.... the trouble started a few weeks back... had a dodgy alternator and it cooked the battery with 18v. Replaced the alternator, but one day while trying to start it on gas with the cooked battery, it backfired and blew off all the vac hoses including the map sensor.... i put it all back on... but i have a stutter now as described.... car otherwise runs great, tis very odd.
Top
 Profile  
 
 
 Post subject: Re: weird stuttering down low when idling on petrol.
Posted: Thu Aug 12, 2010 1:33 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

What are the symptoms of a stuffed map sensor?

Wondering if the same backfire that blew all the hoses off has damaged the map sensor???

cheers

Frank
Top
 Profile  
 
 
 Post subject: Re: weird stuttering down low when idling on petrol.
Posted: Thu Aug 12, 2010 1:46 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 993

Joined: 26th Sep 2007

Gallery: 4 images

Ride: EL Fairmont Ghia

Location: Brisbane
QLD, Australia

ECU could have been damaged. ? Try another one. symtoms of a map sensor fault would be rich running on light throttle. It would have black smoke pouring out the exhaust at idle. Would run like crap, unless under load.

 

_________________

ED Fairmont Barra 190rwkw 4.10 Gears 3500 Stall 1/4 to come

Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Sun Aug 15, 2010 8:20 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

Turns out I was wrong... It isn't just that rev range, it is when you first push the accelerator that it starts stuttering and then picks up.. it happens at higher revs too, it just isn't as noticeable.

SYMPTOMS
----------------
- spluttering Happens only on Petrol upon sudden increase in revs.
- Any sudden increase in throttle causes it at any rev range, but most noticeable down low..
- It slowly comes good after about 5 seconds of spluttering and takes off.

It isn't the map sensor as I just changed it with an identical spare, just cos I had one handy.
I had previously disconnected the ICS to smooth the idle, but I took it off and put a gasket without holes under it to block it and then hooked it back up.. no difference but I wasn't really expecting anything anyway. Also changed the plugs but again, no difference and wasn't really expecting any.

The fact that it only does it on petrol and runs fine on gas makes me think it's fuel or line related but what would cause those symptoms, would crap in the fuel do it? or a blocked fuel filter?


cheers and thanks

Franki
Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Sun Aug 15, 2010 9:16 pm 
Getting Side Ways
Offline

Age: 36

Posts: 9453

Joined: 9th Nov 2004

Gallery: 4 images

Ride: Fordrunner 5.0 Turbo

Location: Wollongong
NSW, Australia

Could be any of the following:
Stale fuel
Blocked fuel filter
Blocked/leaking injectors

Most cabs become like that from not being run on petrol long enough. Nothing to really worry about unless you are pedantic and expect perfect performance for both petrol and LPG.
Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Sun Aug 15, 2010 11:56 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

would hazard a bet its the map. check all the vac hoses again + the fuel reg for a diaphragm blowout

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Mon Aug 16, 2010 12:26 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

Tried a different map sensor.. made no diff.. I think xcabbi is right... I put some injector cleaner in the tank a couple of weeks ago.. I think that it loosened some crap in the tank which is now sitting in the filter.. will swap it out next weekend to see... till then will stay on gas... thanx guys.

Last edited by frankieh on Mon Aug 16, 2010 2:49 am, edited 1 time in total.

Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Mon Aug 16, 2010 2:33 am 
Fordmods Newbie
Offline

Age: 25

Posts: 11

Joined: 15th Jul 2010

Ride: 95 ef falcon gli

Location: eleebana
NSW, Australia

Id saay either fuel filter or fuel pump on its way out? Hopefully only fuel filter though and the crap in the tank hasn't stuffed the pump.
Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Mon Aug 16, 2010 2:50 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

well if it is the pump, I have a walbro 255lt pump here that was going in eventually when the supercharger did.... :-) might be an excuse to get the ball rolling.
Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Mon Aug 16, 2010 3:02 am 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

frankieh wrote:
well if it is the pump, I have a walbro 255lt pump here that was going in eventually when the supercharger did.... :-) might be an excuse to get the ball rolling.


The pump would be whining all the time if it was about to die??????/

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Mon Aug 16, 2010 3:17 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

It sounds like the injectors are not spraying right, but is that due to the injectors, or a clogged fuel filter, a dying fuel pump, fuel pump relay, or even the fpr, or even the fuel lines?

I have a hard starting issue on petrol, none on gas, stumbles around for a few seconds before it will idle, then it's ok. I'm going to swap my injectors for a set known to work ok, and see the results, when the weather is good enough for me to swap them over.

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: weird stuttering when you push the throttle on petrol.
Posted: Mon Aug 16, 2010 12:17 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3440

Joined: 23rd Dec 2007

Gallery: 32 images

Ride: BA XR6T (mix of BA, BF and FG)

Location: Perth
WA, Australia

EL___Fairmont wrote:
frankieh wrote:
well if it is the pump, I have a walbro 255lt pump here that was going in eventually when the supercharger did.... :-) might be an excuse to get the ball rolling.


The pump would be whining all the time if it was about to die??????/


I really think its the filter, when my EA pump died, it didn't whine, I have a fuel reg with a guage inline so if changing the filter doesn't help, I'll put the reg inline and see what it shows for pressure.

cheers

Frank
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 20 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Google Adsense [Bot] and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 11:38 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names