Fordmods Logo

what am i missing? 

 

Page 2 of 3 [ 37 posts ] Go to page Previous  1, 2, 3  Next

 
Posted: Mon Feb 18, 2008 10:46 am 
Fordmods Newbie
Offline

Age: 29

Posts: 10

Joined: 23rd Oct 2006

Ride: EF Falcon

Location: melbourne
VIC, Australia

i just onto wade, they say a 1530 is for a truck...
the previous owner obviously lied to me...
doesnt help much...
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 10:50 am 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

well next step is a 977b regrind :)
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 11:12 am 
Fordmods Newbie
Offline

Age: 29

Posts: 10

Joined: 23rd Oct 2006

Ride: EF Falcon

Location: melbourne
VIC, Australia

just spoke to the owner, he said it was a 1636
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 11:15 am 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

what is he making it up as he goes along?
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 12:03 pm 
Stock as a Rock
Offline

Age: 61

Posts: 156

Joined: 2nd Nov 2005

Ride: EA Fairmont

Location: Canberra
ACT, Australia

Devil_ef wrote:
just spoke to the owner, he said it was a 1636


Do Wade stamp the number on the end of the cam ????
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 12:07 pm 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

gutza wrote:
Devil_ef wrote:
just spoke to the owner, he said it was a 1636


Do Wade stamp the number on the end of the cam ????


not that i know of..... i had two of their cams, and theres no markings that i could see apart from the factory part number
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 1:41 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 10

Joined: 23rd Oct 2006

Ride: EF Falcon

Location: melbourne
VIC, Australia

yer.... checked it he is telling the truth
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 2:35 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 10

Joined: 23rd Oct 2006

Ride: EF Falcon

Location: melbourne
VIC, Australia

i spoke to the owner again and he admitted it was a bit of a slug, he said to goto an efi specialist and get it examined, what do u think about that?
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 3:40 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 10

Joined: 23rd Oct 2006

Ride: EF Falcon

Location: melbourne
VIC, Australia

if the timing has never been done, the cam has never been dialed in, would there be that big of a
difference in the timing from stock to that cam to loose a potential 30rwkw??? as other cars with the
same mods as mine have got?

i changed filters, oils, flushed the coolant
not really a big difference, maybe runs smoother
Top
 Profile  
 
 
Posted: Mon Feb 18, 2008 6:30 pm 
Getting Side Ways
Offline

Age: 29

Posts: 4182

Joined: 30th May 2005

Ride: 1993 EB XR8

Location: BrisVegas
QLD, Australia

get the cam dialed in, and throw a manual in for good measure and it *should* haul a***

 

_________________

ILL60 - EF XR8, Sunroof, Ticky Kit, 19x8.5/19x11 TE37's, 347, AFr185's, TFS BoxRcustom converter, Hurst Quarterstick, huge billet cam.

51TER - DL LTD. Stock.

Top
 Profile  
 
 
Posted: Tue Feb 19, 2008 8:01 am 
Stock as a Rock
Offline

Age: 61

Posts: 156

Joined: 2nd Nov 2005

Ride: EA Fairmont

Location: Canberra
ACT, Australia

Hi There

1. If its defiinately a 1636, then it "should" be OK in the stock position.
But who knows.

2. Take rocker cover off and see if you have vernier gear.
If it does, someone may have fiddled too much with it.
If no vernier gear, it "might" help.

3. Turn engine over by hand and check all rocker gear / arms
and valve springs for cracks and that all are working correctly.

4. Someone please correct if necessary.
Get TDC on No 1. Push rocker onto Cam lobe.
I'm pretty sure there should be a small gap between the tip of
the HLA and the valve stem. This is for inlet and exhaust.
If no gap then the HLA's may be over-shimmed.

5. As suggested, do a compression check.
Top
 Profile  
 
 
Posted: Tue Feb 19, 2008 9:02 am 
Getting Side Ways
Offline

Age: 29

Posts: 2563

Joined: 19th Feb 2007

Gallery: 21 images

Ride: 98 EL Futura

Power: 199 rwkw

Location: Lilydale
VIC, Australia

maybe the engine is just flogged out, headgasket might be on its way out? new leads new plugs? clogged cat? oxy sensor?. I would take the Powerchip out aswell, they are only meant for stock cars, even exhaust systems wil upset them.

 

_________________

EL Futura: CVE head, Wolf V500, ICE Ignition and Coil, 36lb injectors, Walbro 255lb, Paci comps, 3" exhaust, T5, Harrop Truetrac with 3.9s. Now with 198.9rwkw, (~185rwkw and 13.80 @99.1mph) with more power to come

Top
 Profile  
 
 
Posted: Thu Mar 13, 2008 12:42 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 565

Joined: 8th Nov 2004

Ride: 2011 Kia Optima Platinum

Location: Melbourne
VIC, Australia

Devil_ef wrote:
i tried contacting wade on saturday with no luck, but i was able to find out the
profile of the cam from the previous owner its a wade 1530, that means nothing
to me but there you go, the specks werent on their online catalogue, i got a printout
from the previous owner tho anyway heres the specks:

Cam lift - Intake 0.379". Exhaust 0.379".
Advertised duration - Intake 258 degrees. Exhaust 258 degrees.
Duration @ 0.050" - Intake 222 degrees. Exhaust 222 degrees.
Advertised timing - In. opens 19 closes 59. Ex. opens 55 closes 23.
Phase angle - 108 degrees.

the cam lift seems a hell of alot higher than the wade generic profiles, i dont know what
that means but there is also no mention of that profile cam on fordmods, he mentioned
that it was a custom grind but i dont know, does anyone know about this grind?


I've just noticed this thread. The cam that you've got, based on the specs you've been given, is absolutely not one of ours. With a cam lift of 0.379" it would have a valve lift of 0.758". I don't think so. That's 0.234" more valve lift than our 1521A. No way hosey.
Top
 Profile  
 
 
Posted: Thu Mar 13, 2008 12:45 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 565

Joined: 8th Nov 2004

Ride: 2011 Kia Optima Platinum

Location: Melbourne
VIC, Australia

FordFairmont wrote:
gutza wrote:
Devil_ef wrote:
just spoke to the owner, he said it was a 1636


Do Wade stamp the number on the end of the cam ????


not that i know of..... i had two of their cams, and theres no markings that i could see apart from the factory part number


Our cams, in the case of the E series, are stamped on the rear end. Usually, cams are stamped on the front end, but, this is not suitable for the E series Ford cams.
Top
 Profile  
 
 
Posted: Thu Mar 13, 2008 1:43 pm 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

Wade Cams wrote:
FordFairmont wrote:
gutza wrote:
Devil_ef wrote:
just spoke to the owner, he said it was a 1636


Do Wade stamp the number on the end of the cam ????


not that i know of..... i had two of their cams, and theres no markings that i could see apart from the factory part number


Our cams, in the case of the E series, are stamped on the rear end. Usually, cams are stamped on the front end, but, this is not suitable for the E series Ford cams.


what exactly is stamped though? Cause like i mentioned, ive had a 1636 and 977b and both had no markings which let you know what profile it is, however the 977b had a "V" carved into the end of it lol
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 3  [ 37 posts ]  Go to page Previous  1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:15 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names