Fordmods Logo

WHATS WRONG WITH MY barra turbo 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: WHATS WRONG WITH MY barra turbo
Posted: Mon Jul 11, 2011 11:39 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 8

Joined: 13th Nov 2010

Ride: 2004 ba xr6t ute

Location: esperance
WA, Australia

ehy guys just wondering if anyone has herd of this problem before....

after having my ute parked up for a week i took it for a run on sunday and started fine and same again at the servo after my drive i took it to the car wash and went to leave but she wouldnt turn over..

i had full ignition power(dash lights, acc and radio) but nothing not even a half hearted turn over.
i popped the bonnet and on closer inspection it appeard what i believe to be the fuel pump/injectors were ticking when i turned key on...

a friendly passer buy gave me a hand and i decided to try jump it and she started straight away.

i thouhgt no worries flat battery but after sleeping on it realised i still had all ignition power and checked the battery this arvo and it was good and she started up straight away...

do the ecu hace some sort of fail safe or was it just a glich or is some thing f**ked.


any ideas/addvice is greaty appreciated as i miss driving my uteee.
Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Mon Jul 11, 2011 11:41 pm 
Getting Side Ways
Offline
User avatar

Posts: 6168

Joined: 5th Nov 2004

clean the battery terminals - check battery fluid levels - check for tight connection - check earths...

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Mon Jul 11, 2011 11:46 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Sometimes the battery might have enough charge to light all the little things inside the car or even run the stereo for a little while, but not enough to run the starter motor. The starter motor does suck a lot of juice out of the battery. Also how old is the battery? If it's old, it might not have the capability to hold charge for too long. It could also be dropping cells randomly. Also might want to check if your battery is getting charged properly, if not the alternator might need a look at...sometimes the alternator might give enough power to run the car but not enough to charge the battery, so if your alternator is buggered, you're probably running off the battery half the time.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Mon Jul 11, 2011 11:51 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 8

Joined: 13th Nov 2010

Ride: 2004 ba xr6t ute

Location: esperance
WA, Australia

yeh battery fluids where all ridgy dig and i disconnected and cleaned tremails be fore jumping it but nothing. its holding charge i put the multi meter on it after it been parked for 24 hrs and was sweet.

probs be nothing but i dont wanna have to worry everytime i drive it..

thanks guyss
Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Tue Jul 12, 2011 12:04 am 
Stock as a Rock
Offline
User avatar

Age: 38

Posts: 113

Joined: 9th May 2005

Gallery: 9 images

Ride: BFII XR6T

Power: 255 rwkw

Location: Melbourne
VIC, Australia

How old is the battery? I had the same thing happen with my EF, lights and everything worked, even heard the fuel pump wind up, but nada on the ignition. I'd say it's time for a new battery, they certainly don't last forever, I've been told they need changing every two years.

 

_________________

Victoria - The Nanny State of nanny states

Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Tue Jul 12, 2011 12:09 am 
Fordmods Newbie
Offline

Age: 25

Posts: 8

Joined: 13th Nov 2010

Ride: 2004 ba xr6t ute

Location: esperance
WA, Australia

yeh i have had the ute for 11 months on the same battery. i think ill just buy a newy and some jumper leads.

thanks for ur help guys
Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Tue Jul 12, 2011 12:10 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Multimeter is no indication - batterys fail under load.

British electrics were known for similar stuff. in their case there was enough power to turn the car over, but once it was turning over there wasnt enough volts to run the ECU. Lame!
Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Thu Jul 14, 2011 4:48 pm 
Oompa Loompa
Offline

Age: 25

Posts: 27

Joined: 7th Sep 2009

Ride: XR6 Turbo - T56 - 260RWKW

Location: Comboyne
NSW, Australia

Check ignition fuse maybe

 

_________________

2005 BA MKII XR6 Turbo 6 Speed Manual Xforce Exhaust, K&N Filter, C&V Tune @ 260RWKW

Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Fri Jul 22, 2011 6:06 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 6

Joined: 12th Apr 2011

Location: Wollongong
NSW, Australia

I had the same problem with my BA. Went to work in the morning and it started fine. Then a couple of hours later it just died and refused to start. I checked the battery and it was charged and all the connections seemed fine, was pretty strange. Couldn't find out what was wrong with it so I just replaced the battery and its worked fine ever since.
Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Fri Jul 22, 2011 8:33 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 862

Joined: 8th May 2005

Ride: BA Wagon Turbo, Ba Fairlane G220

Location: Colac
VIC, Australia

Yeah mine did the same they recon the battery drops a cell so it reads that its charged but it ain't go no go.

 

_________________

Congo Green Ba Wagon With F6 6 Speed Manual Driveline.

Top
 Profile  
 
 
 Post subject: Re: WHATS WRONG WITH MY barra turbo
Posted: Sat Jul 23, 2011 5:28 pm 
Getting Side Ways
Offline

Age: 35

Posts: 1353

Joined: 15th Mar 2007

Gallery: 7 images

Ride: AU XR6

Power: 171 rwkw

Location: thornton
NSW, Australia

I would suggest there are volts to spare but you're lacking amps my friend.

 

_________________

9/98 AU1 XR6hp-about to retire from the road and be reborn on the race track.
86 ZL mint grandpa spec with premo sound and 150000km
07 TTG 60000km stock as, mods to come.
97 el futura about to be MOCKed

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 11:19 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names