Fordmods Logo

When i Accelerate It revs but car dont go HELP!! 

 

Page 2 of 2 [ 19 posts ] Go to page Previous  1, 2

 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Tue Apr 19, 2011 10:35 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Mine's started doing the same thing again, so this week end I'm replacing the coil pack and leads. I'll let you know the result, if it cures mine then it may be worth a shot on yours.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Sat Apr 23, 2011 3:47 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 72

Joined: 8th Oct 2009

Gallery: 2 images

Ride: FG Falcon XR6

Location: Gold Coast
QLD, Australia

Esteven8 wrote:
Mine's started doing the same thing again, so this week end I'm replacing the coil pack and leads. I'll let you know the result, if it cures mine then it may be worth a shot on yours.


Cheer's mate keep me posted :)

 

_________________

PH4490 Pacemaker Headers
Bullet Hi Flow Cat
2.5" X force Cat Back Mandrel System
K&N Panel Filter
Alteeza Aftermarket Tail Lights
Youtube - http://www.youtube.com/user/straitupmatt

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Sun Apr 24, 2011 2:26 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Done. And what a difference!!!... like a new car now. s**t, cramped, pain in the a** to get at spot.. but worth it for the result.
Have a look at this thread for some helpful info.
http://www.fordmods.com/post1245548.html#p1245548
I took all the intake plastic off as well as the bottom of the air box. Just take care not to pull the oil pressure signal wire out while you've got your arm jammed under the intake manifold. I noticed I'd done it just before I put the air box etc back in thank god!!

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Tue May 03, 2011 5:39 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 72

Joined: 8th Oct 2009

Gallery: 2 images

Ride: FG Falcon XR6

Location: Gold Coast
QLD, Australia

Esteven8 wrote:
Done. And what a difference!!!... like a new car now. s**t, cramped, pain in the a** to get at spot.. but worth it for the result.
Have a look at this thread for some helpful info.
http://www.fordmods.com/post1245548.html#p1245548
I took all the intake plastic off as well as the bottom of the air box. Just take care not to pull the oil pressure signal wire out while you've got your arm jammed under the intake manifold. I noticed I'd done it just before I put the air box etc back in thank god!!


thats the way man :D did u do the spark leads aswell or just coil pack? what was the condition of the coil pack when u took it out. what differance has it made to the old girl since u replaced it compared to before?

 

_________________

PH4490 Pacemaker Headers
Bullet Hi Flow Cat
2.5" X force Cat Back Mandrel System
K&N Panel Filter
Alteeza Aftermarket Tail Lights
Youtube - http://www.youtube.com/user/straitupmatt

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 19 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 39 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 6:24 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names