Fordmods Logo

xg problem fuel problem 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: xg problem fuel problem
Posted: Mon Jan 17, 2011 9:40 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 2

Joined: 17th Jan 2011

Ride: xg ute

Location: innisfail
QLD, Australia

hi all, as the title says, my brothers xg fuel injected 6cyl just cut out on the way back from town yesterday. After pulling over and waiting a bit, the engine started aand ran for about 15 secs then died again. then after sitting over night, it started and ran for about a minute. We assumed it was a fuel prob so went back to town and got a new fuel filter (old one had'nt been changed for 2yrs) fitted it but still same problem? we pulled the fuel inlet off (near the injector rail) and plenty of fuel came through.

a couple of things that might help:
-we had just fueled up at servo as tank was very empty - could of sucked some s%#t through?
- we have been getting a crap load of rain lately and notices a dribble of water leaking behind the (new) computer.

also now after stuffing around, the fuel pump isnt making any sort of noise on start up?

hope somone can help.
cheers!!
Top
 Profile  
 
 
 Post subject: Re: xg problem fuel problem
Posted: Mon Jan 17, 2011 9:41 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Coil 50%
TFI Module on Dizzy 50%

100% :)


Water is the biggest E series killer. (XG based on EB-ED.)

Coil is your most likely culprit, however TFI module is worth replacing first (second hand one from the wreckers at least and takes 10mins,

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: xg problem fuel problem
Posted: Mon Jan 17, 2011 10:03 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 2

Joined: 17th Jan 2011

Ride: xg ute

Location: innisfail
QLD, Australia

thanks for the fast reply mate! ill check it out tomoz.
cheers
Top
 Profile  
 
 
 Post subject: Re: xg problem fuel problem
Posted: Thu Jan 20, 2011 10:25 am 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

all good?

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: DStirrup and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:20 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names