Fordmods Logo

XG Ute 

 

Page 1 of 2 [ 18 posts ] Go to page 1, 2  Next

 
 Post subject: XG Ute
Posted: Sat May 27, 2006 2:51 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 283

Joined: 24th Aug 2005

Gallery: 7 images

Ride: XG Ute

Location: Melbourne
VIC, Australia

Hi guys, i got a xg ute and my engine is annoying me, im loosing coolant somewhere along the line but im not so sure where it is, i had a problem with my original heater valve solinoide thing a while ago and replaced that with a genuine ford part, but the problem is i was away at the time and my dodgy mate put it on coz he wanted to use the car, so i dont know how well it was put on, is there any other non obviouis places it could be escaping? also my car heats up alot in idol when at the lights and stuff but my fan seems to be working ok, and water pump kicks in as soon as i put some revs on, any suggestions as to what that ghost is?

As soon as i can get these issues ironed out its time for some serious mods!!!! Oh and the cars a manual if that makes any difference to the price of fish.

Keep up the good work guys, u helped me out many times before!

 

 

Attachments:
edited 2 (part 5).JPG
edited 2 (part 5).JPG [ 123.77 KiB | Viewed 55 times ]

 

_________________

Its On Like Donky Kong!
Dont take life too seriously, coz ur not goana make it out of it alive!
Pain Is Tempory, Glory Is Forever.
Who Dares Wins.

Top
 Profile  
 
 
Posted: Sat May 27, 2006 8:39 pm 
Getting Side Ways
Offline

Age: 31

Posts: 3772

Joined: 5th Nov 2004

Gallery: 33 images

Ride: EL Fairmont Ghia

Location: Hobart
TAS, Australia

u could be loosing it into the engine
therefore time for a new head gasket
Top
 Profile  
 
 
Posted: Sun May 28, 2006 12:47 am 
Getting Side Ways
Offline

Age: 27

Posts: 1092

Joined: 14th Mar 2006

Ride: 2009 FG XR6 turbo project

Location: perth
WA, Australia

i have an xf that hides under the bonnet one of the very 1st efi's put into fords.... theyre prone to leaking into the motor, dont jump 2 conclusions, chek ur water pump first!! thats wat was wrong with mine.
Top
 Profile  
 
 
Posted: Sun May 28, 2006 1:03 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 283

Joined: 24th Aug 2005

Gallery: 7 images

Ride: XG Ute

Location: Melbourne
VIC, Australia

yea okies, ill check out the water pump n pray like f*@k thats it. my oil isant showing any signs of water in it, so if that makes a difference??
Also i put up a pic up there of what im planing on doing to the outside of the car along with lowering and wheels and exhaust, but i figured i should get the mechanical stuff sorted out first hay?
Anywayz, im stuffed, im goin to bed :)

 

_________________

Its On Like Donky Kong!
Dont take life too seriously, coz ur not goana make it out of it alive!
Pain Is Tempory, Glory Is Forever.
Who Dares Wins.

Top
 Profile  
 
 
Posted: Mon May 29, 2006 12:20 am 
Getting Side Ways
Offline

Age: 27

Posts: 1092

Joined: 14th Mar 2006

Ride: 2009 FG XR6 turbo project

Location: perth
WA, Australia

you should see the utes where i come from... f**k big 5 posters, aerials, mudflaps, led lights, u anem it, theyve got it... i was gonna get an aggie, but my dads a trucky, so i got all i need at my doorstep, minus the ute. lol.

yeh water pump, or u could check the coreplugs under the manifold, ( use a mirror to see underneath )
Top
 Profile  
 
 
Posted: Mon May 29, 2006 8:44 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 283

Joined: 24th Aug 2005

Gallery: 7 images

Ride: XG Ute

Location: Melbourne
VIC, Australia

haha hell yea! where u from? I was goana make a b'n's ute but i gotta still use this thing day to day so i cant go too nuts, so i decided to make it a lil more street.

Yea core plugs, ill check them, that actually didnt come to mind altho it should have, i had to replace them on the old '75 TD courtina 250 pre x-flow i had, man that baby was a beast!
Anyway cheers for the brain power!!

 

_________________

Its On Like Donky Kong!
Dont take life too seriously, coz ur not goana make it out of it alive!
Pain Is Tempory, Glory Is Forever.
Who Dares Wins.

Top
 Profile  
 
 
 Post subject: Cooling problems
Posted: Mon May 29, 2006 8:58 pm 
Getting Side Ways
Offline
User avatar

Age: 42

Posts: 2893

Joined: 24th May 2006

Gallery: 21 images

Ride: XH B&S ute, Navara 4x4

Power: 202 rwkw

Location: Bordertown
SA, Australia

Which engine has youre ute got? Is it a crossflow or the overhead cam motor? My XH has the overhead cam motor (obviously!) and I had trouble with the hose going into the bootom of the overflow bottle. It also used to heat up on idle. I had the radiator recoed and that fixed it. The early engines had trouble with core sand staying in the block and after a few years the radiator would block up with the sh*t! Other wise pull out plug nos 5 and 6 and compare. Chances are that if the head is gone it will be in no 6. This plug will be washed clean compared with 6. Also wind over with no 6 out. Mite get a squirt of water out the plug hole. Hope this helps!! And yes my ute does have a 5 poster and arieals and lights and stickers and.......

 

_________________

You'll ride a black tornado across the western sky

You'll rope an ol' blue norther and milk it 'till it's dry

Bulldog the Diamantina pin its ears down flat

Long before you take this cowboy's hat

Top
 Profile  
 
 
 Post subject: Re: XG Ute
Posted: Mon May 29, 2006 9:25 pm 
Oompa Loompa
Offline

Posts: 22

Joined: 6th May 2006

Location: maitland
NSW, Australia

XGCOWBOY wrote:
Hi guys, i got a xg ute and my engine is annoying me, im loosing coolant somewhere along the line but im not so sure where it is, i had a problem with my original heater valve solinoide thing a while ago and replaced that with a genuine ford part, but the problem is i was away at the time and my dodgy mate put it on coz he wanted to use the car, so i dont know how well it was put on, is there any other non obviouis places it could be escaping? also my car heats up alot in idol when at the lights and stuff but my fan seems to be working ok, and water pump kicks in as soon as i put some revs on, any suggestions as to what that ghost is?

As soon as i can get these issues ironed out its time for some serious mods!!!! Oh and the cars a manual if that makes any difference to the price of fish.

Keep up the good work guys, u helped me out many times before!


first up hi all

yep just bought me a xh ute also - ye haa baby,
and has this prob also. i am having trouble matching the parts up at the auto mobs , like what model sedan the 1997 4.0 ltr motor is in also. so will try all the above suggestions and let yas know how it goes.

one other question is when setting base tuning at the dizzy 10 degrees btdc , where is the shorting connector for the puter to bypass the computer advance??? also what colur should i expect the wires to be ??
Top
 Profile  
 
 
Posted: Tue May 30, 2006 5:49 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

XGCOWBOY wrote:
my oil isant showing any signs of water in it, so if that makes a difference??



Water can leak into combustion chambers and exit out the exhaust without contaminating the oil.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Tue May 30, 2006 10:28 pm 
Getting Side Ways
Offline
User avatar

Age: 42

Posts: 2893

Joined: 24th May 2006

Gallery: 21 images

Ride: XH B&S ute, Navara 4x4

Power: 202 rwkw

Location: Bordertown
SA, Australia

The reason for having trouble matching parts is that when you go to REPCO foe example they punch it into their computer and it comes up with them having the same induction as the later model (ef/el). Compare under the bonnet with an eb and they are the same. I think that that is the trick. When you want parts near induction think eb; all other parts god knows. Could be xf, eb, ed, ef, el. Thats why yhtey were called FRANKENUTES!!!lol :lol:

 

_________________

You'll ride a black tornado across the western sky

You'll rope an ol' blue norther and milk it 'till it's dry

Bulldog the Diamantina pin its ears down flat

Long before you take this cowboy's hat

Top
 Profile  
 
 
Posted: Tue May 30, 2006 10:48 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1092

Joined: 14th Mar 2006

Ride: 2009 FG XR6 turbo project

Location: perth
WA, Australia

catchasim from w.a.. im not from perth, im a country boy... with a "street car" i was heading for a ute, i found my xf advertised as a ute and turns out it wanst, and i fell in love, alot of my mates have aggies, my brother has a feral, 720 DATSUN ute, its f**k grouse ute eh :D . do u have msn? if u do, send us p/m of ur addy and ill send ya some pics :)

catchas
Top
 Profile  
 
 
Posted: Wed May 31, 2006 2:19 am 
Oompa Loompa
Offline

Posts: 22

Joined: 6th May 2006

Location: maitland
NSW, Australia

thanks all
Top
 Profile  
 
 
Posted: Wed May 31, 2006 4:09 pm 
Stock as a Rock
Offline

Age: 35

Posts: 117

Joined: 29th Oct 2005

Ride: EB S XR6

Location: Western Sydney
NSW, Australia

riyder wrote:
thanks all
did u figure out the problem? I put my money on a blocked radiator.

 

_________________

EB S XR6
161kw At The Wheels
14.8 @ 149.92 km\h WSID

Top
 Profile  
 
 
Posted: Thu Jun 01, 2006 6:08 am 
Oompa Loompa
Offline

Posts: 22

Joined: 6th May 2006

Location: maitland
NSW, Australia

new developement so far , hissing sound from rear right hand side of motor when car is warmed up and as soon as i stop motor noise is there, but no water yet ?????
Top
 Profile  
 
 
Posted: Fri Jun 02, 2006 3:34 am 
Oompa Loompa
Offline

Posts: 22

Joined: 6th May 2006

Location: maitland
NSW, Australia

problem seems to have developed into a leaky welsh plug now , as i now got visible water stain on side of block and a constant drip, still fingers crossed its not a head gasket though
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 18 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 3:54 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names