Fordmods Logo

XG with ef motor wont rev under load 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: XG with ef motor wont rev under load
Posted: Thu Jul 21, 2011 6:14 pm 
Oompa Loompa
Offline

Age: 51

Posts: 38

Joined: 30th May 2011

Ride: V8 XG VAN / V8 NL fairlane ghia

Location: Melbourne
VIC, Australia

bought this van 7 months ago and finally thought i better make it run on pterol as well as gas
some of the lpg wires were suss so i got another loom and comp from another car put it in and it still would not run on petrol originally i thought the wiring was the problem

turns out the injectors and rail were blocked
Image
Image
Image
so far new injector rail (well second hand)
injectors
fuel pump pull and flush tank

now it runs on both petrol and lpg

it wont rev under load on petrol revs freely out of gear

its doin my head in :twisted:
Top
 Profile  
 
 
 Post subject: Re: XG with ef motor wont rev under load
Posted: Thu Jul 21, 2011 6:30 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

with the state of those injectors and fuel rail, I'd be checking that there's no crap in the tank and lines and fitting a new fuel filter as a start........that's fair blocked.

Gab
Top
 Profile  
 
 
 Post subject: Re: XG with ef motor wont rev under load
Posted: Thu Jul 21, 2011 6:56 pm 
Oompa Loompa
Offline

Age: 51

Posts: 38

Joined: 30th May 2011

Ride: V8 XG VAN / V8 NL fairlane ghia

Location: Melbourne
VIC, Australia

Gab1 wrote:
with the state of those injectors and fuel rail, I'd be checking that there's no crap in the tank and lines and fitting a new fuel filter as a start........that's fair blocked.

Gab


both done

it will pick up revs slowly when driving but if you push to far it just dies
Top
 Profile  
 
 
 Post subject: Re: XG with ef motor wont rev under load
Posted: Thu Jul 21, 2011 7:24 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

So when you say just dies. Do you mean it floods, leans out or looses spark or what?
Is it auto?
Top
 Profile  
 
 
 Post subject: Re: XG with ef motor wont rev under load
Posted: Thu Jul 21, 2011 7:50 pm 
Oompa Loompa
Offline

Age: 51

Posts: 38

Joined: 30th May 2011

Ride: V8 XG VAN / V8 NL fairlane ghia

Location: Melbourne
VIC, Australia

87SIlude wrote:
So when you say just dies. Do you mean it floods, leans out or looses spark or what?
Is it auto?

auto

its like running out of lpg but on petrol if you flutter the throttle it will pick up slowly
Top
 Profile  
 
 
 Post subject: Re: XG with ef motor wont rev under load
Posted: Sat Jul 23, 2011 11:25 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

what's the fuel pump like? Particularlly if it's had any crap run through it.

Gab
Top
 Profile  
 
 
 Post subject: Re: XG with ef motor wont rev under load
Posted: Sat Jul 23, 2011 6:09 pm 
Oompa Loompa
Offline

Age: 51

Posts: 38

Joined: 30th May 2011

Ride: V8 XG VAN / V8 NL fairlane ghia

Location: Melbourne
VIC, Australia

it was replaced but i'll double check it when i get a chance


thanks

regards Heath
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:11 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names