Fordmods Logo

XH losing power 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: XH losing power
Posted: Wed Aug 17, 2011 3:29 pm 
Smokin em up
Offline
User avatar

Age: 28

Posts: 225

Joined: 16th May 2010

Gallery: 9 images

Ride: 98 XH2 Ute

Location: Toorak
VIC, Australia

been a while since i've been on here but just started to get working on my ute again and now it just runs like complete s**t

it started of "spluttering" like it was going to stall when i put my foot down. now its gotten worse right after i serviced it.

basically what i've done is turned it on and unlcipped each fuel injector to see which ones weren't making a difference when unclipped. 2 of them make absolutely no difference, replaced the 2 with brand new ones and its still the exact same problem. unclip them and there is no difference.

Any ideas of what else i can try? i dont wana take it to a mechanic cos i cant get to work without my ute and each day i take off trying to fix this s**t i lose money. Help please?

 

_________________

98 XH 5 Speed
BA 17"s, BA Short Shifter, 2.5" Mandrel Bent Redback, More To Come!
98 XH 5 Speed - http://www.fordmods.com/the-garage-f53/a-bone-s-98-xh-5-speed-t98900.html

Top
 Profile  
 
 
 Post subject: Re: XH losing power
Posted: Thu Aug 18, 2011 4:23 am 
Parts Gopher
Offline

Age: 53

Posts: 99

Joined: 6th Sep 2010

Ride: 1997 el ford

Location: pearcedale
VIC, Australia

I take it you have replaced plugs leads etc... Are the cylinders that are misfiring together
could be valves or gasket
Top
 Profile  
 
 
 Post subject: Re: XH losing power
Posted: Sun Aug 21, 2011 5:32 pm 
Smokin em up
Offline
User avatar

Age: 28

Posts: 225

Joined: 16th May 2010

Gallery: 9 images

Ride: 98 XH2 Ute

Location: Toorak
VIC, Australia

yeah plugs and leads we're replaced then afterwards was running worse, for some reason i was given 2 dodgey leads, al sorted now

 

_________________

98 XH 5 Speed
BA 17"s, BA Short Shifter, 2.5" Mandrel Bent Redback, More To Come!
98 XH 5 Speed - http://www.fordmods.com/the-garage-f53/a-bone-s-98-xh-5-speed-t98900.html

Top
 Profile  
 
 
 Post subject: Re: XH losing power
Posted: Tue Aug 23, 2011 12:41 pm 
Getting Side Ways
Offline

Age: 50

Posts: 912

Joined: 22nd Mar 2005

Gallery: 1 images

Location: FNQ
QLD, Australia

damn! That sort of thing can be a bugger - I had my EF go stupid - mechs diagnosed buggered coil (using analyser) - so they fitted new coil AND new leads and plugs which I'd already bought for it. Couple of days later the original misfiring / no acceleration / surging started up again. I went ahead with doing the head - which needed doing anyway - and when I got the intake manifold off I found one lead not pushed onto the coilpack properly - grrrrr :evil:

 

_________________

96 EF Auto GLi - Bilstein Shocks - Adjustable Front sway bar - JMM Cam - TI Perf J3 - TCI 2500/3000 stall converter. 2015 Jeep Cherokee Trailhawk.

Top
 Profile  
 
 
 Post subject: Re: XH losing power
Posted: Tue Aug 23, 2011 3:20 pm 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

Check your getting 12v pulses at each injector plug(use a multimeter or 12v test bulb) while cranking or with engine running. If they are all getting power than I would look at the following;

1) fuel filter being blocked/

2) fuel pressure regulator not holding rail pressure

3) fuel leak on the injector rail.

If fuel side of things look good check for good spark at the 2 cylinders causing the trouble--could be bad leads, plugs, contacts on dizzy cap, worn rotor button...etc...

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: XH losing power
Posted: Tue Aug 23, 2011 6:55 pm 
Getting Side Ways
Offline

Age: 50

Posts: 912

Joined: 22nd Mar 2005

Gallery: 1 images

Location: FNQ
QLD, Australia

I think he's got it sorted - was couple of dud leads - his experience raked up bad memories of my own tail chasing caused by "things that should have fixed it first time" syndrome so I was just venting :)

 

_________________

96 EF Auto GLi - Bilstein Shocks - Adjustable Front sway bar - JMM Cam - TI Perf J3 - TCI 2500/3000 stall converter. 2015 Jeep Cherokee Trailhawk.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 8:36 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names