Fordmods Logo

XH Running Rough 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: XH Running Rough
Posted: Mon May 27, 2013 3:47 pm 
Parts Gopher
Offline

Age: 21

Posts: 58

Joined: 27th Aug 2012

Ride: 1999 Ford AU

Location: Horsham
VIC, Australia

Hey Guys,

ive had my XH XR6 for about a month now and it was running like a gem when i first got it but all of a sudden i drove it up the road to a mates house (about 2 mins away) and when i got there it was running rough and when i accelarate its missfiring ! i noticed the exhaust was all cracked out and out the back of the exhaust it was popping and carrying on so i replaced the exhaust and it didnt make a differeance !

i was just wondering if you guys could help me out with what to try ?

Cheers Jesse
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Mon May 27, 2013 5:29 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3452

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

Change your Fuel Filter and the plugs and clean the HEGO. (Oxygen Sensor)
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Mon May 27, 2013 5:35 pm 
Parts Gopher
Offline

Age: 21

Posts: 58

Joined: 27th Aug 2012

Ride: 1999 Ford AU

Location: Horsham
VIC, Australia

i have a new fuel filter and plugs ready to go in !!

if that doesnt help what should i do next ??

Cheers Jesse
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Tue May 28, 2013 1:22 am 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3452

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

There is an electrical sensor attached to the Exhaust, it is called the HEGO sensor, that MAY be the fault.
Is yours the Log manifold or the Other one?
Attachment:
LogM.jpeg


Image

You should check the TPS if it is the Broadband manifold and Throttle Air Valve.
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Tue May 28, 2013 8:03 am 
Parts Gopher
Offline

Age: 21

Posts: 58

Joined: 27th Aug 2012

Ride: 1999 Ford AU

Location: Horsham
VIC, Australia

Yes its the high rise intake manifold, because its XR6.

It looks just like the EF motor, what should I try ??

Jesse
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Tue May 28, 2013 9:50 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Check the s/plugs, HT leads, dizzy cap, rotor, and the coil, for cracks, and stuff like that.

 

 

Attachments:
IMGP3969.JPG
IMGP3969.JPG [ 383.85 KiB | Viewed 44 times ]
IMGP3963.JPG
IMGP3963.JPG [ 272.4 KiB | Viewed 53 times ]
IMGP3965.JPG
IMGP3965.JPG [ 385.87 KiB | Viewed 39 times ]

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Tue May 28, 2013 8:50 pm 
Parts Gopher
Offline

Age: 21

Posts: 58

Joined: 27th Aug 2012

Ride: 1999 Ford AU

Location: Horsham
VIC, Australia

Yeah I will replace the fuel filter and spark plugs and give it a oil change !

How is the best way.to remove distributor and everything ?

Cheers
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Tue May 28, 2013 11:39 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3452

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

.
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Wed May 29, 2013 8:41 am 
Parts Gopher
Offline

Age: 21

Posts: 58

Joined: 27th Aug 2012

Ride: 1999 Ford AU

Location: Horsham
VIC, Australia

What's the best way to remove the distributor cap and.rotor button ?

Cheers
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Wed May 29, 2013 9:12 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

You'll need to disconnect the HT leads at the plugs, and the coil ( underneath the intake manifold) so as to facilitate removal of the dizzy cap.
You will need to remove the CAI tube so you can gain access as well.
There isn't a lot of room for the cap and leads (BBM intake) as they will connect with the intake runners.....so some patience will be required.
To properly inspect the coil, it will need to be removed, and possibly the mounting bracket as well.
The pic of the failed ignition coil was from an EL Falcon that had about 160K on it.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Wed May 29, 2013 11:18 am 
Parts Gopher
Offline

Age: 21

Posts: 58

Joined: 27th Aug 2012

Ride: 1999 Ford AU

Location: Horsham
VIC, Australia

Ok thanks guys !
Top
 Profile  
 
 
 Post subject: Re: XH Running Rough
Posted: Thu Jun 06, 2013 8:04 pm 
Parts Gopher
Offline

Age: 21

Posts: 58

Joined: 27th Aug 2012

Ride: 1999 Ford AU

Location: Horsham
VIC, Australia

Last weekend I changed the oil and filter, the fuel filter and fitted new spark plugs but didnt make it run any better !

So this weekend I am going to replace the leads, distributor cap and the rotor button !!

If this doesn't help, what's next ? Getting sick of it running like s**t !
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 12:52 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names