Fordmods Logo

XH ute revving 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: XH ute revving
Posted: Wed May 16, 2012 9:32 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 2

Joined: 19th Apr 2012

Ride: XH UTE

Location: NEWCASTLE
NSW, Australia

have an XH ute. problem is it wants to idle at 2 grand to 2600 rpm, but only once the go pedal has been pushed. i can torque up the car (being manual) and it drops the revs back down to 800rpm. tried a few things but now starting to get into some dollars. any suggestions and help would be appreciated
Top
 Profile  
 
 
 Post subject: Re: XH ute revving
Posted: Wed May 16, 2012 9:55 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

documents.php?d=23

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: XH ute revving
Posted: Wed May 16, 2012 10:20 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 2

Joined: 19th Apr 2012

Ride: XH UTE

Location: NEWCASTLE
NSW, Australia

i thought that might be the problem so already replaced it last week. as well as the plugs, leads, rotor cap and button, maf sensor, and alot of other bolt on parts i could think of. it makes it better for a day or two but still comes back. ute is doing about 500km a day
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 34 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 9:00 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names