Fordmods Logo

XH XR6 acceleration problems 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: XH XR6 acceleration problems
Posted: Tue Jul 05, 2005 10:28 pm 
Getting Side Ways
Offline

Age: 31

Posts: 597

Joined: 19th Jun 2005

Gallery: 4 images

Ride: 98 XH XR6

Location: Diamond creek
VIC, Australia

i recently bourght a XR6 5 speed ute and found when you plant your foot through 1st and 2nd the car really really struggles to pick up and piss of.
i have just had my injectors cleaned, brand new exhaust from cat converter to tip, fuel and air filters changed, fuel lines checked and cleaned and am on the way to change the oxygen switch. any help would be appreciated

 

_________________

ONE FOR RUM AND RUM FOR ALL

4.0ltr 1998 XH XR6 - 2 JVC 4way 6X9's - 2 JVC 4way 4" in doors - JVC head unit - AU XR8 intake snorkel


Paceys, hi flow cat and many more still to come

Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 10:38 pm 
Getting Side Ways
Offline

Age: 32

Posts: 972

Joined: 6th Feb 2005

Gallery: 6 images

Ride: XHII pano, Landau

Location: S.E Subs
VIC, Australia

you sure it not your clutch

 

_________________

Automatics only come in assult riffles
---------------------------------------
www.aussiecoupes.net

Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 10:41 pm 
Getting Side Ways
Offline

Age: 31

Posts: 597

Joined: 19th Jun 2005

Gallery: 4 images

Ride: 98 XH XR6

Location: Diamond creek
VIC, Australia

nah clutch is all good

 

_________________

ONE FOR RUM AND RUM FOR ALL

4.0ltr 1998 XH XR6 - 2 JVC 4way 6X9's - 2 JVC 4way 4" in doors - JVC head unit - AU XR8 intake snorkel


Paceys, hi flow cat and many more still to come

Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 10:46 pm 
Getting Side Ways
Offline

Age: 32

Posts: 972

Joined: 6th Feb 2005

Gallery: 6 images

Ride: XHII pano, Landau

Location: S.E Subs
VIC, Australia

and im guessing you changed your fuel filter when u checked the fuel lines.........i cant think of anything else :(

Someone will know, just takes time

 

_________________

Automatics only come in assult riffles
---------------------------------------
www.aussiecoupes.net

Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 10:52 pm 
Getting Side Ways
Offline

Age: 31

Posts: 597

Joined: 19th Jun 2005

Gallery: 4 images

Ride: 98 XH XR6

Location: Diamond creek
VIC, Australia

yeah changed all that just s**t you it runs crap i dunno what it could be

 

_________________

ONE FOR RUM AND RUM FOR ALL

4.0ltr 1998 XH XR6 - 2 JVC 4way 6X9's - 2 JVC 4way 4" in doors - JVC head unit - AU XR8 intake snorkel


Paceys, hi flow cat and many more still to come

Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 10:55 pm 
Getting Side Ways
Offline

Age: 31

Posts: 597

Joined: 19th Jun 2005

Gallery: 4 images

Ride: 98 XH XR6

Location: Diamond creek
VIC, Australia

yeah changed all that just s**t you it runs crap i dunno what it could be

 

_________________

ONE FOR RUM AND RUM FOR ALL

4.0ltr 1998 XH XR6 - 2 JVC 4way 6X9's - 2 JVC 4way 4" in doors - JVC head unit - AU XR8 intake snorkel


Paceys, hi flow cat and many more still to come

Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 11:04 pm 
Smokin em up
Offline

Age: 36

Posts: 241

Joined: 11th Dec 2004

Ride: Ed falcon

Location: kellyville
NSW, Australia

check your map sensor?

Neil

 

_________________

HSV I JUST BEAT ONE !

AFF 05 NSW DYNO DAY STATE CHAMP

Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 11:33 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1052

Joined: 12th Nov 2004

Ride: NC II Fairlane

Location: Newcastle
NSW, Australia

put a better cam in it :) otherwise i thinks its only normal as falcon 6's pick up in 3rd gear

 

_________________

"Looking at cleavage is like looking at the sun. You don't stare at it. It's too risky. You get a sense of it and then you look away."

Now with el thermos fitted.

Top
 Profile  
 
 
Posted: Wed Jul 06, 2005 12:32 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

Have you had the code pulled from the ECU. There may be a dodgy sensor which is causing your problems.

Could be TFI, Coil, leads, one of the sensors. Seems you have done all the fuel related items, maybe need to look at igniton side.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: Facebook [Bot], Google Adsense [Bot] and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 1:28 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names