Fordmods Logo

xh2 probs 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: xh2 probs
Posted: Fri Aug 12, 2005 12:36 am 
Fordmods Newbie
Offline
User avatar

Age: 33

Posts: 10

Joined: 7th Aug 2005

Ride: BA XR8 Ute

Location: Inverell
NSW, Australia

Hey'all
i have an xh2 longreach ute and around the 1800rpm till 2500rpms it jerks and misses then goes good again does anyone know wat would cause this?
Cheers
[/b]
Top
 Profile  
 
 
Posted: Fri Aug 12, 2005 12:44 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 1085

Joined: 6th Nov 2004

Ride: BF XR Turbo

Location: Castle Hill
NSW, Australia

i know a couple of xh guys have had troubles with blocked cats?? possibility?

 

_________________

BF XR6T 6spd Auto. 60lb injectors, Hybrid Cooler, Custom Piping, Custom Surge Tank, Actuator.

12.3 @ 114

Top
 Profile  
 
 
Posted: Fri Aug 12, 2005 2:09 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Is your XH dual fuel, or petrol only ???

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Fri Aug 12, 2005 6:56 pm 
Smokin em up
Offline

Posts: 276

Joined: 2nd Aug 2005

Location: brisbane
QLD, Australia

i have s imilar problem. not quite that bad but from what the mechanic has told me and from what i know it is a blocked exhaust. and from the last couple of messages it appears to be a blocked cat.

mine also lacks in power a bit. the blocked exhaust doesnt help
Top
 Profile  
 
 
Posted: Fri Aug 12, 2005 10:03 pm 
Getting Side Ways
Offline

Age: 37

Posts: 775

Joined: 27th Nov 2004

Ride: BA XT Series 2

Location: Cairns
QLD, Australia

Check uf fuel filter also

 

_________________

Stage 1 stereo install done. Pics in audio section.
Next step is probably a nice exhaust or stage 2 stereo.

Top
 Profile  
 
 
Posted: Sat Aug 13, 2005 9:43 am 
Fordmods Newbie
Offline
User avatar

Age: 33

Posts: 10

Joined: 7th Aug 2005

Ride: BA XR8 Ute

Location: Inverell
NSW, Australia

hey
it doesnt have dual fuel tanks and the exhaust should be fine coz i only got it a few months ago 2 1/2" and high flow cat. The fuel filter is only 10000klms old, i might change the plugs, leads and fuel filter and c wat happens i'll get back to yas
cheers
Top
 Profile  
 
 
Posted: Sat Aug 13, 2005 8:22 pm 
Stock as a Rock
Offline

Age: 35

Posts: 149

Joined: 6th Nov 2004

Ride: XH Ute

Location: Dandenong
VIC, Australia

same problem i had and it turned out to be the TPS (throttle positioning switch)
Just had my mechanic pull it out, re tap it and back in, no dramas now!

 

_________________

The Ute with the Most

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 12:04 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names