Fordmods Logo

Amp problems - missing grub screws and missing crossover 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Amp problems - missing grub screws and missing crossover
Posted: Sat Apr 26, 2008 7:16 pm 
Getting Side Ways
Offline
User avatar

Posts: 1863

Joined: 30th Apr 2006

Location: Melbourne
VIC, Australia

Hi All,

I have an old school Kicker ZR360 amp lying around which I was hoping to use.

It works fine, but I have got 2 problems with it.

Firstly, it's missing the grub screws for the power and earth wiring. Does anyone know where I could purchase new grub screws?


Secondly, I don't have a crossover module for it. The Kicker ZR series of amps had a plug in crossover module, mine just has a full range one. I've been watching out on ebay, but have not yet come across a low pass one.

Does anyone know where I'd be able to get the correct low pass crossover module, or is it possible to get an external one?

Thanks,

Justin.
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 1:32 am 
Getting Side Ways
Offline

Age: 65

Posts: 971

Joined: 11th Jan 2005

Ride: BA MK11

Location: West Melbourne
VIC, Australia

Try Jaycar.

 

_________________

The older I get the better I was!

Top
 Profile  
 
 
Posted: Sat May 03, 2008 10:03 pm 
Getting Side Ways
Offline
User avatar

Posts: 1863

Joined: 30th Apr 2006

Location: Melbourne
VIC, Australia

Well, looks like I could just build/buy an external crossover, but I would prefer to get the correct Kicker module.

Anyone got any ideas?
Top
 Profile  
 
 
Posted: Sat May 03, 2008 10:07 pm 
Smokin em up
Offline
User avatar

Age: 44

Posts: 251

Joined: 22nd Mar 2006

Gallery: 7 images

Ride: EF XR6 manual

Location: S.E. Melbourne
VIC, Australia

I'll ask some mates that do installs, can't promise anything but no harm in asking :wink:

 

_________________

EF XR6 5spd 14.57@97mph
154rwkwts

Top
 Profile  
 
 
Posted: Sat May 03, 2008 10:10 pm 
Getting Side Ways
Offline
User avatar

Posts: 1863

Joined: 30th Apr 2006

Location: Melbourne
VIC, Australia

grub73 wrote:
I'll ask some mates that do installs, can't promise anything but no harm in asking :wink:


Thanks mate, that'd be great! I know it's a big ask given the amps probably 6 years old or so!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 12:24 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names