Fordmods Logo

Car won't start? 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Car won't start?
Posted: Thu Dec 27, 2007 4:08 pm 
Getting Side Ways
Offline

Posts: 436

Joined: 20th Jun 2005

Gallery: 1 images

Ride: Gli

Location: melbourne
VIC, Australia

Me and a mate we're installing a new JVC headunit into my DF LTD and we had just start, we hooked up ground and power but they accidentally touched and i blew a fuse. Pretty sure it was the door lock fuse so i changed that but i still can't get the car to start, any ideas guys?
Top
 Profile  
 
 
Posted: Thu Dec 27, 2007 4:16 pm 
Getting Side Ways
Offline

Age: 36

Posts: 3794

Joined: 9th Aug 2005

Ride: Hilux

Location: Mornington
VIC, Australia

did you check all of the fuses?

 

_________________

Now driving a Hilux

Top
 Profile  
 
 
Posted: Thu Dec 27, 2007 8:14 pm 
Stock as a Rock
Offline

Age: 38

Posts: 119

Joined: 27th Jul 2006

Ride: EF II wagon

Location: adelaide/salisbury north
SA, Australia

check the dome light bulb, guy next door did the same think and this blew

 

_________________

EF2 wagon stockstandard with plenty of leaks and other problems

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 5:59 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names