Fordmods Logo

Clarion head unit playing games 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Clarion head unit playing games
Posted: Mon Nov 22, 2010 10:42 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Hi all,
On Thursday I got a 2nd hand Clarion Head unit (DXZ676USB) for the EF, put it in, wired it up and was enjoying finally having a decent sounding stereo in the wagon. Until Saturday, when I put the face on the stereo, started the car and... nothing. :( No sound, no lights... Nada.
At first I thought a loose connection so when I got back I pulled it out and checked everything out. All the wiring is fine, the constant power feed is fine as is the power from the acc circuit and the earth. There is power to the unit, I took the cover off the and plugged it in and sure enough, power in the thing all the way up to the face plate connection. But nothing works.
Any ideas? I would like to get this unit fixed if possible, as the sound it puts out (while it worked :) ) was pretty good. I have a fairly basic (well, limited) understanding of electronics so is there anywhere I may be able to take this to get it sorted?
Thanks in advance

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: Clarion head unit playing games
Posted: Tue Nov 23, 2010 2:15 am 
Smokin em up
Offline
User avatar

Age: 31

Posts: 276

Joined: 14th Apr 2009

Gallery: 12 images

Ride: Fairmont Ghia BA 5.4L V8, AU 6

Power: 205 rwkw

Location: Perth
WA, Australia

Hey Mate,

Check the terminals on the back of the facia, they may be dirty and not giving the best contact. I sometimes clean mine with one of those green rough kitchen sponge things.

 

_________________

Chaos, Panic and Disorder. My work here is finally done.
BA Fairmont Ghia 5.4L. Mods -Full Exhaust, Chipped, Custom Intake, CAI @205.4RWKW.
Stezza - Alpine Type R Splits & 6x9's, Alpine 400w RMS 4ch, 380w RMS Pioneer Mono, 2x12" Pioneer Subs and an AVH-P5950DVD Player.

Top
 Profile  
 
 
 Post subject: Re: Clarion head unit playing games
Posted: Tue Nov 23, 2010 10:22 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Fairmont_03_5.4 wrote:
Hey Mate,

Check the terminals on the back of the facia, they may be dirty and not giving the best contact. I sometimes clean mine with one of those green rough kitchen sponge things.

Ok I gave that a go and still nothing :( But thank you anyway, it was something I hadn't even considered.
I noticed something else too, the red LED that blinks when the facia is off isn't blinking either and also, when I turn the key to ACC there is no sound from the stereo. It used to whir and click a little when it got power off the ACC feed, but not any more. So it's not looking too promising. I'm wondering if there is an electronics place who might know their way around a car stereo?

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: Clarion head unit playing games
Posted: Tue Nov 23, 2010 6:20 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 276

Joined: 14th Apr 2009

Gallery: 12 images

Ride: Fairmont Ghia BA 5.4L V8, AU 6

Power: 205 rwkw

Location: Perth
WA, Australia

Hey Dude,

Yeah it sounds like your accessory wire is not working properly. What i do when this happens is i hook up the battery and the accessories lead from the deck straight upto the positive on the battery to test that the deck operates. If the deck does turn on then you need to find another accessories wire. Also, you may have wired up the Accessories wire on the deck upto the illumination circuit that lights up the dash when you turn the lights on.

But yeah, try disconnecting the Accessories wire coming out of the deck and connected that and the main power lead directly to the battery to check that the deck is not at fault.

The easiest place i found in my BA to run and accessories lead was from the Cigarette Lighter.

Good Luck,

 

_________________

Chaos, Panic and Disorder. My work here is finally done.
BA Fairmont Ghia 5.4L. Mods -Full Exhaust, Chipped, Custom Intake, CAI @205.4RWKW.
Stezza - Alpine Type R Splits & 6x9's, Alpine 400w RMS 4ch, 380w RMS Pioneer Mono, 2x12" Pioneer Subs and an AVH-P5950DVD Player.

Top
 Profile  
 
 
 Post subject: Re: Clarion head unit playing games
Posted: Sat Nov 27, 2010 11:21 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

SORTED!!!! :) :) :) :)
Went to my local Autobarn and got the number for Clarion Aust ((03) 8558 1115 if anyone else has issues with Clarion audio equipment, they are extremely helpful) , gave 'em a call and the tech guy ran through a list of possibilities, but the 1st thing he suggested was to unplug the unit for about 48hrs and then plug it back in, as sometimes they can lock up electronically if they have not had power running through them for a while. It was out of a car for a while before I put it in mine. Did so and it fired up without a problem and I'm back to enjoying my music again!! :)

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 2:26 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names