Fordmods Logo

disortion in one of my subs 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: disortion in one of my subs
Posted: Wed Sep 07, 2005 7:37 pm 
Getting Side Ways
Offline

Age: 31

Posts: 442

Joined: 7th Jan 2005

Gallery: 7 images

Ride: EF SERIES II FAIRMONT

Location: ADELAIDE, KLEMZIG
SA, Australia

hey, all of a sudden one of my subs has started to distort like as if something inside the sub has come off. i have taken the sub out of the box and had a look at it and it looks fine to the eye but as soon as you touch the front of the sub it starts to rattle. what could this be.

it is so bloody annoying not being able to use my subs, now i drive with all my windows down so i can hear the exhaust instead, lol.

 

_________________

FORD 1996 EF FAIRMONT ARGON SILVER
18 INCH GT-P WHEELS
POWERCHIP,AWESOME STEREO,MONSTER FLOW POD FILTER
KYB LOWERED SHOCKs & KINGSPRING SUPERLOWS
XTRACTORS 2.5 INCH PIPES HI-FLOW CAT SML STRAIGHT THRU MUFF TWIN TIPS
DBA STREET SERIES SLOTTED ROTORS
*IT'S MY PRIDE & JOY*

Top
 Profile  
 
 
Posted: Wed Sep 07, 2005 7:56 pm 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

could be that the voice coil has detatched itself from the cone

 

_________________

Banned

Top
 Profile  
 
 
Posted: Wed Sep 07, 2005 8:01 pm 
Getting Side Ways
Offline

Age: 31

Posts: 442

Joined: 7th Jan 2005

Gallery: 7 images

Ride: EF SERIES II FAIRMONT

Location: ADELAIDE, KLEMZIG
SA, Australia

well from what i can see everything is attached. the cone looks fine and is attached. is there anything below the voice coil that could come off?

 

_________________

FORD 1996 EF FAIRMONT ARGON SILVER
18 INCH GT-P WHEELS
POWERCHIP,AWESOME STEREO,MONSTER FLOW POD FILTER
KYB LOWERED SHOCKs & KINGSPRING SUPERLOWS
XTRACTORS 2.5 INCH PIPES HI-FLOW CAT SML STRAIGHT THRU MUFF TWIN TIPS
DBA STREET SERIES SLOTTED ROTORS
*IT'S MY PRIDE & JOY*

Top
 Profile  
 
 
Posted: Wed Sep 07, 2005 8:08 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 10826

Joined: 17th Apr 2005

Gallery: 34 images

Ride: BF MK11 XR 6 TURBO ZF 6spd

Power: 225 rwkw

Location: glenwood/sydney
NSW, Australia

does the spider smell like a plastic/glue burniong smoke smell??? mighta cooked it!!! if putting too much rms power into it...

 

_________________

Todd: Nurse, suction.
Nurse: The patient's not even here yet.
Todd: I know.

http://www.youtube.com/watch?v=_GQpRYRcAiA

Top
 Profile  
 
 
Posted: Wed Sep 07, 2005 8:11 pm 
Getting Side Ways
Offline

Age: 31

Posts: 442

Joined: 7th Jan 2005

Gallery: 7 images

Ride: EF SERIES II FAIRMONT

Location: ADELAIDE, KLEMZIG
SA, Australia

nah nothing is burning, i am only run 445 rms as the place where i got my subs (complete audio) ran my two subs off a mono block alpine amp so there is no way they could have blown and it was running no gain at all just pure bass. any ideas anyone?????

 

_________________

FORD 1996 EF FAIRMONT ARGON SILVER
18 INCH GT-P WHEELS
POWERCHIP,AWESOME STEREO,MONSTER FLOW POD FILTER
KYB LOWERED SHOCKs & KINGSPRING SUPERLOWS
XTRACTORS 2.5 INCH PIPES HI-FLOW CAT SML STRAIGHT THRU MUFF TWIN TIPS
DBA STREET SERIES SLOTTED ROTORS
*IT'S MY PRIDE & JOY*

Top
 Profile  
 
 
Posted: Wed Sep 07, 2005 9:20 pm 
Tyre Shredder
Offline
User avatar

Age: 51

Posts: 377

Joined: 22nd May 2005

Gallery: 7 images

Ride: NF Fairlane V8

Location: Melbourne
VIC, Australia

Well it sounds like the voice coil breaking up.. You say both subbies are run off a mono amp so it can't be a channel in the amp..
You can't see the coils in a speaker unless you cut the cone out, check this out it shows things better http://electronics.howstuffworks.com/speaker5.htm..

 

_________________

The TORQUE Monster project begins!

Pic's, details and all the yummy stuff:
http://www.fordmods.com/forums/viewtopic.php?t=22693

"There's no replacement for displacement!"

Top
 Profile  
 
 
Posted: Wed Sep 07, 2005 9:27 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

It may be that the resin on the coil windings has burnt resulting in them scratching on the outer surface.
Does it make the noise if you gently push the cone in? If so you will need the cone replaced, if your luckt it may just have to be aligned again.
Top
 Profile  
 
 
Posted: Sat Sep 10, 2005 7:29 pm 
Getting Side Ways
Offline

Age: 31

Posts: 442

Joined: 7th Jan 2005

Gallery: 7 images

Ride: EF SERIES II FAIRMONT

Location: ADELAIDE, KLEMZIG
SA, Australia

joolz, that is exactly what it does u push the cone and it makes a scratching noise, if it needs to be aligned do you reckon that will be covered by warranty???

 

_________________

FORD 1996 EF FAIRMONT ARGON SILVER
18 INCH GT-P WHEELS
POWERCHIP,AWESOME STEREO,MONSTER FLOW POD FILTER
KYB LOWERED SHOCKs & KINGSPRING SUPERLOWS
XTRACTORS 2.5 INCH PIPES HI-FLOW CAT SML STRAIGHT THRU MUFF TWIN TIPS
DBA STREET SERIES SLOTTED ROTORS
*IT'S MY PRIDE & JOY*

Top
 Profile  
 
 
Posted: Sat Sep 10, 2005 8:12 pm 
Moderator
Offline
User avatar

Age: 39

Posts: 4653

Joined: 5th Nov 2004

Ride: Drives Like Fun

Power: 318 rwkw

Location: Melbourne Interior: Cappucino Exterior: Sparkling Burgundy
VIC, Australia

turbofairmont wrote:
nah nothing is burning, i am only run 445 rms as the place where i got my subs (complete audio) ran my two subs off a mono block alpine amp so there is no way they could have blown and it was running no gain at all just pure bass. any ideas anyone?????


Only 445 rms ? That is quite a bit of power there - don't dismiss it as not much...if your gains are perhaps setup outside the subwoofer tolerances, you can do damage also.

Just bear in mind - with big power systems nowadays, speakers are always going to cop the most 'work' in a system...anything with moving parts is going to wear over time...longevity is largely based on build / design quality of the speaker and how they are used in their application.

 

_________________

Vic Cruises & Events

Top
 Profile  
 
 
 Post subject: problem found
Posted: Mon Oct 10, 2005 6:29 pm 
Getting Side Ways
Offline

Age: 31

Posts: 442

Joined: 7th Jan 2005

Gallery: 7 images

Ride: EF SERIES II FAIRMONT

Location: ADELAIDE, KLEMZIG
SA, Australia

not sure if u guys remember this one but i found out the problem. the voice coil was split, bent and burnt. the guys i bought off believed that it was a faulty sub as my other one should have blown since they are running off of a mono block amp

 

_________________

FORD 1996 EF FAIRMONT ARGON SILVER
18 INCH GT-P WHEELS
POWERCHIP,AWESOME STEREO,MONSTER FLOW POD FILTER
KYB LOWERED SHOCKs & KINGSPRING SUPERLOWS
XTRACTORS 2.5 INCH PIPES HI-FLOW CAT SML STRAIGHT THRU MUFF TWIN TIPS
DBA STREET SERIES SLOTTED ROTORS
*IT'S MY PRIDE & JOY*

Top
 Profile  
 
 
 Post subject: Re: problem found
Posted: Mon Oct 10, 2005 6:35 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 8655

Joined: 5th Nov 2004

Gallery: 37 images

Ride: V8 EF Futura

Location: Adelaide CBD
SA, Australia

turbofairmont wrote:
not sure if u guys remember this one but i found out the problem. the voice coil was split, bent and burnt. the guys i bought off believed that it was a faulty sub as my other one should have blown since they are running off of a mono block amp


Nice. So i assume completes replaced it for you?

 

_________________

I promise..... I will never die.

Fordmods Administration Group MINOR PUNKED

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 7:02 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names