Fordmods Logo

Eclipse Head Units 

 

Page 2 of 2 [ 28 posts ] Go to page Previous  1, 2

 
Posted: Wed Apr 20, 2005 6:08 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1097

Joined: 10th Nov 2004

Gallery: 10 images

Ride: GU patrol, XH XR6, Isuzu Mux

Location: Mackay
QLD, Australia

what is wrong with running the front speakers through the HU there is a bit of power comin out of the HU mite as well not waste it.


Interceptor - Capricornia Training Company. Stay away from Mrayle they are even worse!

 

_________________

' 96 Xh XR6 Ute
'96 DF LTD 6cy
'08 GU Nissan Patrol
'15 Isuzu MUX LST

Top
 Profile  
 
 
Posted: Wed Apr 20, 2005 10:10 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

voids wrote:
what is wrong with running the front speakers through the HU there is a bit of power comin out of the HU mite as well not waste it.


Interceptor - Capricornia Training Company. Stay away from Mrayle they are even worse!


Well a HU is never gonna bring out the potensial of the speakers due to thier lack of power, even a good HU with 4X60 rating wont do. Thats why amps kick a**! :)

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
Posted: Thu Apr 21, 2005 11:43 am 
Oompa Loompa
Offline

Age: 33

Posts: 32

Joined: 9th Mar 2005

Location: Melbourne
VIC, Australia

i have had nothing but good experience with the eclipse headunits. my mum has one in her vw passat and she knows nothing about most things when it comes to audio equpiment, but she has no trouble using it at all. even with the remote control. they may not look as flash as say an alpine, but imo they are far superior in out right performance. i highly recomend them. :D
Top
 Profile  
 
 
Posted: Thu Apr 21, 2005 3:22 pm 
Tyre Shredder
Offline
User avatar

Age: 33

Posts: 332

Joined: 5th Nov 2004

Location: Melbourne
VIC, Australia

voids wrote:
what is wrong with running the front speakers through the HU there is a bit of power comin out of the HU mite as well not waste it.


Personally, I think if you're after a head unit that offers so much high sound quality (it doesn't have 8 volt pre outs for amps for nothing), then there is not much point having the front speakers running off the head unit (if you've got the rears amped).

Sound quality applications will have 75%-100% of all mids and highs coming from the front as that's where the driver is obviously and a sub to take care of lows. Rear speakers are merely "fill" in most SQ apps.

And let's be honest, <20wrms from a head unit is pretty tiny. Do the Eclipse units require a dedicated power source direct from the battery? I know the higher end Alpine units support 26wrms and get power straight from the battery. Don't be fooled by "60w * 4 channels", as that's not nominal RMS wattage.

Just my opinion though :D

EDIT: The unit you're looking at has 2.7 volt preouts. However, the internal "amp" can only supply 13wrms... I still stick with my point!! :P
Top
 Profile  
 
 
Posted: Thu Apr 21, 2005 6:08 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1097

Joined: 10th Nov 2004

Gallery: 10 images

Ride: GU patrol, XH XR6, Isuzu Mux

Location: Mackay
QLD, Australia

i dont realy want to be running 3 amps in it tho. it will kill the battery, a i wont be able to play it with the engine off as much as i do. but i recon an eclipse unit would still have to sound better then a premo HU tho? even when not running the fronts through an amp.

 

_________________

' 96 Xh XR6 Ute
'96 DF LTD 6cy
'08 GU Nissan Patrol
'15 Isuzu MUX LST

Top
 Profile  
 
 
Posted: Fri Apr 22, 2005 2:26 am 
Tyre Shredder
Offline
User avatar

Age: 33

Posts: 332

Joined: 5th Nov 2004

Location: Melbourne
VIC, Australia

Ideally you'd run one two channel for the fronts, rears off the headunit, and a mono block for the sub. Otherwise if you want them all amped, a four channel for the front and rear and a mono block for the sub.

But yeah, whatever you do it will sound loads better than a factory unit!
Top
 Profile  
 
 
Posted: Sat Apr 23, 2005 7:58 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1097

Joined: 10th Nov 2004

Gallery: 10 images

Ride: GU patrol, XH XR6, Isuzu Mux

Location: Mackay
QLD, Australia

had a listen to some head units today and was suprised!

first went to alpine and listened to a mid range alpine HU with a set of type R splits. sounded ok but a bit of distortion at higher volumes. and then tryed running the type R speakers with a the same HU but with an amp. there was a big difference loads less distortion and better sound.

then i went to the Eclipse dealer and had a listen to the a same priced eclipse HU through a set of splits. I was Blown Away by the unit!! it sounded amazing. The Eclipse HU running splits without an amp sounded a s**t load better then the allpine unit running type R splits through an amp!!
the Eclipse Made the Alpine look pretty Ordinary.

i think my choice has been made!

 

_________________

' 96 Xh XR6 Ute
'96 DF LTD 6cy
'08 GU Nissan Patrol
'15 Isuzu MUX LST

Top
 Profile  
 
 
Posted: Sat Apr 23, 2005 10:10 pm 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

ideally you'll be running all speakers off an external amp..... HU amps are a big compromise

 

_________________

Banned

Top
 Profile  
 
 
Posted: Sun Apr 24, 2005 6:43 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1097

Joined: 10th Nov 2004

Gallery: 10 images

Ride: GU patrol, XH XR6, Isuzu Mux

Location: Mackay
QLD, Australia

i'll connect it without an amp at first and see how it sounds.. but listening to it without an amp at the shop i would be more then happy with the sound. the guy at the shop recons the speakers that he was running the eclipse HU from where 100W rms

 

_________________

' 96 Xh XR6 Ute
'96 DF LTD 6cy
'08 GU Nissan Patrol
'15 Isuzu MUX LST

Top
 Profile  
 
 
Posted: Sun May 01, 2005 2:50 pm 
Oompa Loompa
Offline

Age: 36

Posts: 26

Joined: 23rd Mar 2005

Ride: EF 95'

Location: Wodonga West
VIC, Australia

I have an Eclipse HU and i love the thing. ESN is great but just make sure you tell the mechanic who is working on your car to not worry about it when he connects the battery back up.

I forgot to tell them and when they fixed my car and replaced the battery they must of wanted to test that things were working. but all the HU said was "Insert CD" and so they got a CD from who knows were and tried to play it, but they tried 3 times with the wrong CD and locked out my HU. I had to call Eclipse and get it unlocked using passwords and codes. I don't keep the CD in my car.

I also have the Eclipse amp and Sub in the boot. waiting on $$$ to get 4 speakers and a 4-ch amp for em. Eclipse all the way :)

LN

 

_________________

Stock apart from 2.5" Exhaust and Headunit.

Top
 Profile  
 
 
Posted: Sun May 01, 2005 10:46 pm 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 10126

Joined: 5th Nov 2004

Gallery: 4 images

Ride: EF Gli Ghia, XP Fairmont

Location: Perth
WA, Australia

which eclipse HU you have?

 

_________________

Owning 1 of 67612 EF GLi Sedans made
FACT: "Chuck Norris owns the greatest Poker Face of all-time. It helped him win the 1983 World Series of Poker despite him holding just a Joker, a Get out of Jail Free Monopoly card, a 2 of clubs, 7 of spades and a green #4 card from the game Uno."

Top
 Profile  
 
 
Posted: Sun May 01, 2005 11:17 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

Swap the fronts and rears.

Amp fronts, use HU for the rears, they're only for 'fill' anyway.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
Posted: Sat May 07, 2005 9:31 pm 
Oompa Loompa
Offline

Age: 36

Posts: 26

Joined: 23rd Mar 2005

Ride: EF 95'

Location: Wodonga West
VIC, Australia

Happy wrote:
which eclipse HU you have?


I have the CD3413 HU, with an 33240 2ch Amp and 87121 Sub.

LN

 

_________________

Stock apart from 2.5" Exhaust and Headunit.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 28 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 11:03 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names