Fordmods Logo

EF Falcon Aerial not working? 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: EF Falcon Aerial not working?
Posted: Tue Apr 25, 2006 11:07 pm 
Fordmods Newbie
Offline

Posts: 11

Joined: 4th Dec 2005

Location: Sydney
NSW, Australia

Hey,
The Aerial on my EF Falcon Does not automatically go up?
what should i do?
should i change to a manual, pull up yourself one?
Top
 Profile  
 
 
Posted: Thu Apr 27, 2006 12:34 am 
Parts Gopher
Offline
User avatar

Age: 34

Posts: 52

Joined: 2nd Feb 2005

Ride: AU I XR6 VCT

Location: Sydney
NSW, Australia

i would first check fuses then maybe grab a test light adn check to see if u are getting power to the motor itself. May just require something simple or could be something like a motor ie stripped gears or broken mast cable.
If you are not sure how to make these checks drop into a ford dealer or your local mechanic adn get them to check out whats going on. Its a reasonably inexpensive common fault with the falcs (when i say inexpensive i mean under 500) so see how you go with it

 

_________________

drive it like it was built to be driven

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 1:24 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names