Fordmods Logo

kicker amp turning on and off when car is off 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: kicker amp turning on and off when car is off
Posted: Mon May 13, 2013 8:20 pm 
Stock as a Rock
Offline

Age: 27

Posts: 199

Joined: 27th Jun 2008

Gallery: 9 images

Ride: EF 2 Fairmont. AU 5 Litre ute

Location: Berwick
VIC, Australia

Hi guys iv got a kicker amp turning itself on and off when the car is off. I had a my dad hook the sub and amp up for me and we had the signal wire tapped into the aerial. So after a year iv have decided to move it and now this is happening. Even with the signal wire wired back into the aerial it still does it. Im thinking tje amp is stuffed. If it helps my head unit is a sony xplod and and 12inch kicker sub.
Any help would be great other wise I'll take it to a audio place.
Top
 Profile  
 
 
 Post subject: Re: kicker amp turning on and off when car is off
Posted: Thu May 16, 2013 5:16 am 
Oompa Loompa
Offline

Posts: 47

Joined: 26th May 2011

Ride: Falcon Xr6 BA

Location: Sydney
NSW, Australia

hey sounds like the remote cable could be cut somewhere..

does it also do this when the car is on ?

and if you moved the amp you may have just pulled a wire loose..

by signal cable im assuming you mean the remote cable ?

if so i think your better off connecting it right to the headunit to avoid any 3rd party issues
Top
 Profile  
 
 
 Post subject: Re: kicker amp turning on and off when car is off
Posted: Thu May 16, 2013 12:17 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Question...by car is off, do you mean the stereo is off too and the amplifier is switching itself on and off? Or do you mean when the car is off and stereo running the amp switches on and off, but stays on if the car is on with stereo on?

As Phillip KG said, I'd check the wires again. You may have knocked something loose after moving it.

Check the earth...make sure the amp is earthed correctly. A bad earth can cause an amp to power down. If you moved the amp and earth point, make sure wherever the earth is attached to has good bare metal to earth to.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:02 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names