Fordmods Logo

Poor EL radio reception 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Poor EL radio reception
Posted: Sat Mar 27, 2010 7:00 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 5

Joined: 27th Mar 2010

Ride: EL Falcon Futura

Location: Adelaide
SA, Australia

Hello,
I know the question has been asked many times before, but I've tried many things and I'm still stumped.
Ever since installing my pioneer PB800BT headunit about 6 months ago my radio reception has been very poor. I've replaced the aerial, and I have just purchased a new aerial cable to go between the aerial and the head unit. Is there anything in particular which the aerial cable shouldn't be run next too? (ie ecu)
If replacing the aerial doesn't do the job what could you suggest I could use to improve radio reception? I spend lots of time in the car each week and the crackling of the radio is driving me insane and makes having good speakers pointless. Has anybody used an aerpro aerial amplifier?

Thanks.
Top
 Profile  
 
 
 Post subject: Re: Poor EL radio reception
Posted: Tue Mar 30, 2010 6:39 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 22nd Feb 2010

Location: Canberra
ACT, Australia

First thing I would do is to check the aerial plug to make sure that it has been plugged in properly.
There are 2 different types of areial plugs and you can get a convertor to suit.

Second, try moving the cable away from all electricial sources: ECU, etc...

Finally, it could be a problem with the headunit itself.
Top
 Profile  
 
 
 Post subject: Re: Poor EL radio reception
Posted: Tue Mar 30, 2010 7:18 pm 
Tyre Shredder
Offline
User avatar

Posts: 340

Joined: 4th Nov 2009

Ride: EFII Fairmont XR8

Location: hobart
TAS, Australia

Yeah I'd be leaning towards the H/U.

Is it earthed properly?

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: Poor EL radio reception
Posted: Tue Mar 30, 2010 9:15 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 5

Joined: 27th Mar 2010

Ride: EL Falcon Futura

Location: Adelaide
SA, Australia

Yeh head unit is earthed properly and the aerial is also earthed to the body. Will pull head unit out this weekend hopefully and check connection and replace aerial cable running from head unit too aerial and avoid anything electrical. If no luck may have to try aerial amp or new h/u :(
Top
 Profile  
 
 
 Post subject: Re: Poor EL radio reception
Posted: Thu May 20, 2010 6:25 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 5

Joined: 27th Mar 2010

Ride: EL Falcon Futura

Location: Adelaide
SA, Australia

have tried replacing aerial and have upgraded hu earth. no luck yet... reception is still poor.
guessing it must be the head unit, trouble is its only a few years old but out of warranty :(
Top
 Profile  
 
 
 Post subject: Re: Poor EL radio reception
Posted: Thu May 20, 2010 11:49 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

Try running a short wire from the ground on the antenna plug at the h/u end to the h/u body.

Just making sure the grounding circuit is working properly, it is a Pioneer.

Also, when you swapped the aerial, did you clean the grounding point under the guard properly. They can get very dirty and corroded over time.
Top
 Profile  
 
 
 Post subject: Re: Poor EL radio reception
Posted: Fri May 21, 2010 5:11 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 5

Joined: 27th Mar 2010

Ride: EL Falcon Futura

Location: Adelaide
SA, Australia

the ground was pretty good at the aerial.

will try running an earth wire from the antenna plug to h/u body and hope for the best
Top
 Profile  
 
 
 Post subject: Re: Poor EL radio reception
Posted: Sat May 22, 2010 6:42 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 5

Joined: 27th Mar 2010

Ride: EL Falcon Futura

Location: Adelaide
SA, Australia

just tried what you told me and didn't seem to make any difference...
seems worse when the car is running.
I would go buy a new head unit but don't know if that would fix the problem
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:43 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names