Fordmods Logo

premium sound system (help) 


Page 1 of 1 [ 2 posts ] 

 Post subject: premium sound system (help)
Posted: Wed Oct 24, 2007 1:07 pm 
Fordmods Newbie

Age: 31

Posts: 7

Joined: 22nd Oct 2007

Gallery: 4 images

Ride: el gt rep

Location: adelaide
SA, Australia

Ok I got a EF fairmont ghia with the premium sound system,

I got a new double din touch screen deck for it as the old one was playen up a lil
I installed it all lastnight got the front speakers all hooked up and working but with the rear they run off the amp along with the sub, I wanna keep the existing amp and speakers with sub….

At the deck it runs 1 big plug with 4 wires 3 are big black ones (rca) and 1 blue one to power the amp, ive hooked the amp one to the accessories wire,
But not 100% sure what to do with the rca wires? As there are 3 rca’s yellow, red and white. And only 2 at the deck like normal. (white and red)

What do yas recommend?

Was thinking of running new rca’s but like I said there are 3 at the amp and 2 at the deck?





Posted: Wed Oct 24, 2007 2:51 pm 
Getting Side Ways
User avatar

Age: 44

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

I would assume that the red and white are your left and right and the third on would be for the sub. You need a xover that will provide the low pass for the sub and high pass for the rears....



Do it once, Do it right!!!!!!

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 6:20 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names