Fordmods Logo

problems with premium sound 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: problems with premium sound
Posted: Mon May 28, 2007 2:47 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 930

Joined: 6th Nov 2004

Ride: EB SXR6 | ED XR8 Sprint

Location: Sydney
NSW, Australia

there seems to be an issue with premium sound fitted to the old mans ef ghia, everything works fine except for the cd, when you press cd on the deck nothing happens at all, when you try to eject a cd from the stacker again nothing happens,

also the rear speakers dont work at all. i checked power going to the amp it seems to be fine, i connected the stacker straight to the HU and still nothing changed. it really has got me stumped, this all happened after i ripped the dash out to change the heater core, everything was spot on prior to this.

ive narrowed it down to either a problem with the HU itself or a problem with the amp, no idea what though.

if anyone has any info or can help out it would be greatly appreciated as it is really ticking me off!

cheers,

 

_________________

EB SXR6. ED XR8 Sprint.

Top
 Profile  
 
 
Posted: Sun Jun 03, 2007 11:28 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 930

Joined: 6th Nov 2004

Ride: EB SXR6 | ED XR8 Sprint

Location: Sydney
NSW, Australia

any ideas anyone??

 

_________________

EB SXR6. ED XR8 Sprint.

Top
 Profile  
 
 
Posted: Sun Jun 03, 2007 8:58 pm 
Tyre Shredder
Offline

Age: 28

Posts: 391

Joined: 26th Mar 2007

Ride: eb

Location: frankston
VIC, Australia

mate id start by ripping the dash out again and checking all plugs and connections and also make sure that you check the rca leads because the rear speakers and sub run off the amp and the front have nothing to do with it so the amp isnt getting any signal from the head unit. hope that helps a bit
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 6:36 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names