Fordmods Logo

Stereo Keeps on cutting out 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Stereo Keeps on cutting out
Posted: Tue Mar 18, 2008 3:03 pm 
Oompa Loompa
Offline
User avatar

Age: 29

Posts: 25

Joined: 2nd Jan 2007

Gallery: 10 images

Ride: EL Futura

Location: Gladstone
QLD, Australia

I need an answer as to why my subs keep on cutting out then coming back on when i have beats turned up. sometimes the speakers drop out aswell. I upgraded my alternator to a 100amp job and installed a 1 farad cap aswell. I have a feed from my battery through a circuit breaker to bus bars in the boot where i have a 12v+ and a 12v- which supply individual power feeds to both my sub and speaker amps. I think it could be that my battery is buggered from not being fully charged due to the old alternator being buggered. Or it colud somesort of protection cut off in the amp. If anyone has a suggestion it would be muchly appreciated.
Cheers

 

_________________

96 EL Futura, Manual, 20'' Xoni Diva, XR6 Headlights, Venom Kit, Full Custom Cream Interior, Cold Air, Extractors, 3'' intake pipe + HEAPS MORE COMING. Hehe

Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 3:25 pm 
Stock as a Rock
Offline

Age: 35

Posts: 187

Joined: 30th Dec 2006

Ride: 95 EF I

Location: Melbourne
VIC, Australia

if its distorting most amps have a cutout, also overtemp cutout if the amps are getting hot...

how long do they stay off for? are your lights dimming when theres a lot of bass from the subs?
Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 4:02 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 948

Joined: 3rd Mar 2006

Gallery: 11 images

Ride: BA XR6 Ute

Location: Brisbane - Perth
QLD, Australia

Check the temp of the Amps and Maybe get some fans.

 

_________________

nascentes morimur

Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 4:14 pm 
Tyre Shredder
Offline

Age: 28

Posts: 391

Joined: 26th Mar 2007

Ride: eb

Location: frankston
VIC, Australia

how big are your subs could be that they are to big for the amp
Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 4:19 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3184

Joined: 8th Nov 2004

Gallery: 6 images

Ride: EF Falcon

Location: Townsville
QLD, Australia

sounds silly, but is your fuse holder of good quality?

i had a lot ( i mean bloody s**t) of problems with my old amp cutting out, and it turned out that the fuse was loose in the fuse holder, so every now and then it would drop out for no apparent reason. fixed it by putting a small bit of solder wrapped in a coil onto the top of the fuse. Sounds bodge, but worked really well. Just had to put in a new bit of solder every 6 months or so cause it would eventually melt and not keep it contacting that hard anymore.

actually, just read you have two amps, so if one if dropping out and one isnt, it wont be that. but helpful for anyone else who has a similar problem

 

_________________

Nicco's M112 Blown, T-56 equipped EF
forums/viewtopic.php?t=68319

Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 6:15 pm 
Tyre Shredder
Offline

Posts: 302

Joined: 1st Jan 2007

Power: 158 rwkw

is the power cable of a big enough guage?
Top
 Profile  
 
 
 Post subject: Stereo Keeps on cutting out
Posted: Wed Mar 19, 2008 10:51 am 
Oompa Loompa
Offline
User avatar

Age: 29

Posts: 25

Joined: 2nd Jan 2007

Gallery: 10 images

Ride: EL Futura

Location: Gladstone
QLD, Australia

the sub amp does get quite warm after a little while. could be cutting out on thermal overload? but sometimes both the subs and the spaekers cut out and both amps have a seperate feed from the bus bars. they cut out for a matter of a few seconds then come back on then off again until i turn the music down. i replaced the speaker amp a couple of weeks ago with an alpine v power good one. i think that it might be time to do the subs amp aswell as it is a prettty old clarion. ill post up some pics of the install soon to show how it has been done.
Cheers

 

_________________

96 EL Futura, Manual, 20'' Xoni Diva, XR6 Headlights, Venom Kit, Full Custom Cream Interior, Cold Air, Extractors, 3'' intake pipe + HEAPS MORE COMING. Hehe

Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 10:56 am 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 948

Joined: 3rd Mar 2006

Gallery: 11 images

Ride: BA XR6 Ute

Location: Brisbane - Perth
QLD, Australia

I'd be going with some bigger guage cabling then. or better quality

 

_________________

nascentes morimur

Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 5:45 pm 
Oompa Loompa
Offline
User avatar

Age: 29

Posts: 25

Joined: 2nd Jan 2007

Gallery: 10 images

Ride: EL Futura

Location: Gladstone
QLD, Australia

I dont thinhk the cable size is an issue. its pretty big gear mate 4 gauge i think maybe even bigger

 

_________________

96 EL Futura, Manual, 20'' Xoni Diva, XR6 Headlights, Venom Kit, Full Custom Cream Interior, Cold Air, Extractors, 3'' intake pipe + HEAPS MORE COMING. Hehe

Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 5:55 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Are you running separate RCA's from the head unit to each amplifier? If you didn't, then check the RCA cables are in properly...they might be jumping around or the cables may have been cut/squashed somewhere along where ever you ran it down.

It could also be a bad earth. Make sure the contacts are good.

Also amps could be running hot and therefore shuts itself down like someone others have said.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Thu Apr 03, 2008 6:59 pm 
Stock as a Rock
Offline

Posts: 121

Joined: 9th Jan 2008

Location: syd
NSW, Australia

u still having probs man?

 

_________________

||EL FAIRMONT||
ALPINE TYPE R 12'S K&N POD SHIFT KIT
2.5"REDBACK MANDRELL BENT
||WANT||
19'S TYPHOON KIT RESPRAY :)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 3:00 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names