Fordmods Logo

Air con common problem? 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: Air con common problem?
Posted: Sat Feb 10, 2007 8:10 pm 
Smokin em up
Offline

Posts: 200

Joined: 3rd Oct 2005

Ride: XC GXL

Location: Townsville
QLD, Australia

Gday all
Just asking whether anybody knows any common leak points
In EB II air conditioners??

My aircon is gone and the bloke that had it before me said that he had it regassed but the gas was all gone the next day..... He also said something about there being a pice of rubber behind the dash that had cracked and gone..Is this a common problem or am I just unlucky because it seems like a HUGE job ... also how much would repair costs be or difficulty to do it myself ...also any other things I should check first?

Thanks again guys
Top
 Profile  
 
 
Posted: Sat Feb 10, 2007 8:13 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

yeah it can happen a fair bit. not sure for quotes but could get back 2 you by monday.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Sat Feb 10, 2007 8:14 pm 
Smokin em up
Offline

Posts: 200

Joined: 3rd Oct 2005

Ride: XC GXL

Location: Townsville
QLD, Australia

ok cheeres mate....and again for the speedy reply
Top
 Profile  
 
 
Posted: Sat Feb 10, 2007 8:14 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Theres prob somone on here that will answer that before I get back 2 ya lol.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Sat Feb 10, 2007 8:18 pm 
Smokin em up
Offline

Posts: 200

Joined: 3rd Oct 2005

Ride: XC GXL

Location: Townsville
QLD, Australia

ahah hope so ...but im in no huge rush in any case .. Could probably do the work myself its just knowing what the hell im doing or....... not knowing what im doing to be technical and if is worth the work just to find its something else ...is there anyway me or the aircon people can test to find where the leak is?
Top
 Profile  
 
 
Posted: Sat Feb 10, 2007 8:19 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

not really sure but I dont think so.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Mon Feb 12, 2007 11:58 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 18

Joined: 3rd Dec 2006

Ride: Mondeo

Location: Perth
WA, Australia

ay mate, if need be i can ask the auto sparky/aircon guy at my work, he owes me a favour and i live in perth so i might be able to help
Top
 Profile  
 
 
Posted: Tue Feb 13, 2007 9:06 am 
Technical Contributor
Offline
User avatar

Posts: 691

Joined: 1st Jun 2005

Ride: EFII Sedan

Location: Brisbane
QLD, Australia

The radiator places pour in some fluorescent dye with the oil so that leaks will show under a UV light later on.

Anywhere there is a join with an o-ring is a possible spot for a leak, but the system on my EB leaked because the condenser/evaporator (can't remember correct name) had been corroded from leaves and s**t building up behind the dash over time. If you remove your glovebox and unscrew the little black fan speed controller (bank of resistors), shine a torch in there and see if you have said buildup. Mine was quite obviously stuffed with a large corrosion hole in it.

The price to get it fixed is 90% labour, as the heater/ac box needs to be removed from the vehicle, disasembled, and replaced if this is your problem.

Regassing is around $60-$80 last time I checked. There are two o'rings on the pipes that connect to the compressor, as well as the large compressor o-ring itself. theres 4 (i think) o-rings that go to the TX valve - the part that connects to the evaporator behind the dash (the two pipes poke thru the firewall to teh engine bay and the TX valve is connected to this)

I did my AC myself with just a new filter/drier and core, and got the gas place to fill it. Saved a LOT of money, and its not hard - just time consuming.

 

 

Attachments:
File comment: new filter/dryer
DCP03888x.JPG
DCP03888x.JPG [ 278.55 KiB | Viewed 39 times ]
File comment: out of car and split apart
DCP03880.JPG
DCP03880.JPG [ 303.43 KiB | Viewed 55 times ]
File comment: The TX Valve
DCP03889.JPG
DCP03889.JPG [ 267.38 KiB | Viewed 51 times ]
File comment: New vs Old cores
DCP03881.JPG
DCP03881.JPG [ 347.06 KiB | Viewed 63 times ]
File comment: removing from behind the dash
DCP03882.JPG
DCP03882.JPG [ 282.03 KiB | Viewed 51 times ]

 

_________________

EF II Sedan
Ex Chaser, Dual Fuel (Impco LPG)
LSD High, 3.23, Black wheels, other shiny bits.

EB II Sedan <--- R.I.P. (Rest in pieces - gone to the wreckers for $50...... bargain!)

Top
 Profile  
 
 
Posted: Tue Feb 13, 2007 3:14 pm 
Tyre Shredder
Offline
User avatar

Age: 27

Posts: 365

Joined: 14th Feb 2006

Ride: BA falcon

Location: Adelaide
SA, Australia

well done

 

_________________

Real Men Smoke Rubber

Top
 Profile  
 
 
 Post subject: Re: Air con common problem?
Posted: Tue Feb 13, 2007 3:23 pm 
Getting Side Ways
Offline
User avatar

Posts: 649

Joined: 20th Mar 2005

Gallery: 2 images

koperety wrote:
Gday all
Just asking whether anybody knows any common leak points
In EB II air conditioners??

My aircon is gone and the bloke that had it before me said that he had it regassed but the gas was all gone the next day..... He also said something about there being a pice of rubber behind the dash that had cracked and gone..Is this a common problem or am I just unlucky because it seems like a HUGE job ... also how much would repair costs be or difficulty to do it myself ...also any other things I should check first?

Thanks again guys


Same diagnosis for my EBII....
Got it looked at about a year ago, and quoted $700 to fix as the
whole dash has to come out. Yep, a sizable job alas.
Needless to say, I havent had it done yet so summer is HOT in the car..
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 3:35 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names