Fordmods Logo

ba heater problems 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: ba heater problems
Posted: Wed Aug 30, 2006 9:50 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1298

Joined: 4th Apr 2006

Ride: BA 3v ute

Location: Melbourne
VIC, Australia

in the last week or so whenever i put the heater on in the mornings it takes about 10min for it to work! before it used to work in under a min and its getting real annoying trying to demist my front windows :| is there anything i can do to check it or is it best going to ford? and would something like that be under warrenty?

 

_________________

www.bseries.com.au/punktured

Top
 Profile  
 
 
Posted: Wed Aug 30, 2006 9:53 pm 
Getting Side Ways
Offline

Age: 30

Posts: 4609

Joined: 29th Jul 2005

Gallery: 10 images

Ride: BOXCAR

Location: Launceston
TAS, Australia

could be the heater tap. When it does finally work, does it blow as hot as it used to?

 

_________________

^^^ What He Said

<a href="http://www.fordmods.com/forums/viewtopic.php?t=44952" target="_blank" class="postlink"> TAS Cruises</a>

Top
 Profile  
 
 
Posted: Wed Aug 30, 2006 10:28 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1298

Joined: 4th Apr 2006

Ride: BA 3v ute

Location: Melbourne
VIC, Australia

ye the hot air blows normal after

 

_________________

www.bseries.com.au/punktured

Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 3:22 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

If the car is under a 'new car' warranty take it back to Ford.

I don't see it being the heater tap. Heater taps are normally open without vacuum, and as the heater eventually gets warm, suggests the tap is open.

Does the engine temp warm up as quick as it use too? Might be a stuck thermostat.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 5:24 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1298

Joined: 4th Apr 2006

Ride: BA 3v ute

Location: Melbourne
VIC, Australia

well hows this, water was a lil low in the radiator, filled it up and heater worked straight away this morn :|

 

_________________

www.bseries.com.au/punktured

Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 5:39 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

if its low find out where it leaks and get it fixed under warranty. common spots are radiator side tanks. water pump o'ring. also heater cores (will leak on top of gearbox) and thermostat housings
Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 5:44 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4849

Joined: 19th Feb 2005

Gallery: 1 images

Ride: BA Falcon Suzy Across

Power: 178 rwkw

Location: melbourne
VIC, Australia

its always taken my car about 2 minute b4 it starts blowing hot air out, I thgouh it was normal seeing as my EA would take 25 minutes before it worked.

 

_________________

178.3 rwkw
15.1@96 mph
Now with 3.9 shrooms

Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 6:03 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 948

Joined: 3rd Mar 2006

Gallery: 11 images

Ride: BA XR6 Ute

Location: Brisbane - Perth
QLD, Australia

took mine in, all BA's had O ring leaks on the water pump, they just space the mout and seal them up, 100 bucks i think it cost me, well needed though. never had another problem

 

_________________

nascentes morimur

Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 9:58 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1298

Joined: 4th Apr 2006

Ride: BA 3v ute

Location: Melbourne
VIC, Australia

ye i dont know if there's a leak, had a look at the ground after but didnt see anything, and i've been hearing alot of water noises behind the dash and i got no idea what the hell its from :| i think i have to bring it up with ford when they check out my gear box and a few other things

 

_________________

www.bseries.com.au/punktured

Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 11:07 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

another interesting point, BA's dont have a heater tap...

its normal for it to be a few minutes (until the car is at operating temperature, but u usally feel it start to get warm within a minute or 2)
Top
 Profile  
 
 
Posted: Thu Aug 31, 2006 11:09 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

smiley235 wrote:
its always taken my car about 2 minute b4 it starts blowing hot air out, I thgouh it was normal seeing as my EA would take 25 minutes before it worked.


i'd say the ea had a stuck thermostat
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 5:44 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names