Fordmods Logo

climate control fan works on high only. 

 

Page 1 of 1 [ 15 posts ] 

 
 Post subject: climate control fan works on high only.
Posted: Wed May 28, 2008 1:55 pm 
Smokin em up
Offline

Posts: 243

Joined: 28th May 2008

Location: willawarin
NSW, Australia

hihg guys im new.as the title atates my climate control fan only works on high.any help with this would be great.
Top
 Profile  
 
 
Posted: Wed May 28, 2008 5:59 pm 
Smokin em up
Offline

Posts: 243

Joined: 28th May 2008

Location: willawarin
NSW, Australia

can anyone help??
Top
 Profile  
 
 
Posted: Wed May 28, 2008 6:01 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

If this is an EL, that is normal.

More details about car please. :roll:

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Wed May 28, 2008 6:03 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

If they only come on high with climate control off, then u need to replace relays in front of the air box, 3 for EL and 4 for EF - only 1 or 2 will be faulty thou... like i said more details please

If the above is the case, then ur car is overheating to at least 104.5 deg celcius

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Wed May 28, 2008 6:17 pm 
Smokin em up
Offline

Posts: 243

Joined: 28th May 2008

Location: willawarin
NSW, Australia

its an eb fairmont wagon,i am sorry i wasnt sure if the model would make a difference.the head has been done and it has a new water pump.as silly as it seems it only happened after installing a new electric aerial,which btw doesnt work either
Top
 Profile  
 
 
Posted: Wed May 28, 2008 6:19 pm 
Smokin em up
Offline

Posts: 243

Joined: 28th May 2008

Location: willawarin
NSW, Australia

if the car was running that hot the gauge would show that wouldnt it.
Top
 Profile  
 
 
Posted: Wed May 28, 2008 6:24 pm 
Smokin em up
Offline

Posts: 243

Joined: 28th May 2008

Location: willawarin
NSW, Australia

i should have explained sorry that it is the case on air and fresh.so yeah it is all the time,but the car only sits just above cold at all times.
Top
 Profile  
 
 
Posted: Wed May 28, 2008 7:34 pm 
Smokin em up
Offline

Posts: 243

Joined: 28th May 2008

Location: willawarin
NSW, Australia

please fellas any ideas.
Top
 Profile  
 
 
Posted: Wed May 28, 2008 7:38 pm 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

Guys, read the original post.... He is talking about the Climate Control fan..... You know.... airconditioning!!!

It is most likely that you have a dodgy fan speed controller..... and it will have nothing to do with the engine temperature of your motor.

Can be replaced easily...... just need to get access to the front of the HVAC airbox which is behind the glove box!

Should be able to get one nice and cheap from a wrecker too!!

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
Posted: Wed May 28, 2008 7:52 pm 
Smokin em up
Offline

Posts: 243

Joined: 28th May 2008

Location: willawarin
NSW, Australia

thank you mate,i was starting to panick.yeah i meant the air fan not the thermo.so do i need to pull the glove box out its self to access that?
Top
 Profile  
 
 
Posted: Wed May 28, 2008 8:02 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

WOOPS :oops: :oops: :oops: :oops: :oops:

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Wed May 28, 2008 8:40 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

familyhack wrote:
thank you mate,i was starting to panick.yeah i meant the air fan not the thermo.so do i need to pull the glove box out its self to access that?


OK, considering that this would appear to be your first go at anything like this, go and buy a Gregory's manual. This will become one of the most important tools in maintaining, repairing and modifying your car.

It will describe how and where and what order to do things.

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
Posted: Wed May 28, 2008 9:29 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

familyhack wrote:
its an eb fairmont wagon,i am sorry i wasnt sure if the model would make a difference.the head has been done and it has a new water pump.as silly as it seems it only happened after installing a new electric aerial,which btw doesnt work either
Check you haven't blown a fuse or two.
If you need another fan speed controller, make sure it's the right one: http://www.fordmods.com/forums/viewtopic.php?t=65287

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Thu May 29, 2008 3:55 am 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

I had this problem in my EF Ghia. It was a faulty climate control module in the dash.

Swapped it out with one from the wreckers, no problem!

Mike, Oz

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
Posted: Thu May 29, 2008 7:59 am 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

As a final note : There are several revisions of the Fan Speed controller, and they arent compatible. When you go to your wrecker make sure you have your current one in mind (photo?) and match the part number if you can (93daxxx, 91daxxx, 89daxx..) OR... match the connectors. They also changed.

You should be right with a unit from a pre 7/92 (and maybe later) EB fairmont, ghia or fairlane one.

Removing them is 3 screws, possibly 4. Take your time - it does get around some of the vacuum stuff under the dash and you dont want an air leak in their.

Nigel
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 15 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 12:19 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names