Fordmods Logo

dam potholes!! 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: dam potholes!!
Posted: Tue Jul 03, 2007 12:57 am 
Parts Gopher
Offline

Age: 28

Posts: 72

Joined: 27th May 2007

Ride: xf ute

Location: perth
NSW, Australia

hit a big one out bush today and now my speedo dosnt work(digital)
im thinking the wire on the back of the cluster or where it hook up (to the gearbox i think?) has broken
any ideas? i can fix it myself if its just a broken cable but could it be worse?
cheers
Top
 Profile  
 
 
Posted: Tue Jul 03, 2007 1:15 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

By saying it doesn't work, do you mean as in the digital figure "0" still comes up but does not chance as you speed up? or the whole digital screen does not turn on?

If the whole screen don't turn on then it probably is most likely a behind the dash problem. If it is not changing but still on, then it may be the wiring at the speed sensor on the tranny box, or as you said, the back of the cluster. Check the wiring at the box if it is easier for you to get to it, if not then do the cluster, which ever is easiest at first :P

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Tue Jul 03, 2007 1:38 am 
Parts Gopher
Offline

Age: 28

Posts: 72

Joined: 27th May 2007

Ride: xf ute

Location: perth
NSW, Australia

yeh it just displays "0" ill have a look tomorrow might fix my tacho.. and fuel gauge while im there hahaha
Top
 Profile  
 
 
Posted: Tue Jul 03, 2007 10:27 pm 
Parts Gopher
Offline

Age: 28

Posts: 72

Joined: 27th May 2007

Ride: xf ute

Location: perth
NSW, Australia

yeh just a 3 pin plug was disconected all fixed!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:23 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names