Fordmods Logo

Dash etc not working 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Dash etc not working
Posted: Tue Jan 02, 2007 10:13 am 
Stock as a Rock
Offline

Age: 35

Posts: 131

Joined: 6th Nov 2004

Ride: XH Ute

Sometimes when I start the XH the dash (including ventilation and radio) do not work. I initially assumed there was a dodgy earth or similar somewhere, however it only happens on start up (and seems to becoming more frequent) and only restarts when it feels like it (sometimes only a couple of seconds, sometimes a couple of minutes). I am assuming there must be an electrical gizmo (possibly the BCM) that must be on its way out.
The problem includes: no dash illumination (or of ventilation controls), no ventilation, the radio and CB (which I wired into the cigarette lighter) do not work etc.
Any thoughts will be appreciated.
I couldnt locate another thread, so I hope this is not a double up.
Top
 Profile  
 
 
Posted: Tue Jan 02, 2007 11:03 am 
Stock as a Rock
Offline

Age: 47

Posts: 156

Joined: 21st Oct 2006

Location: Morwell
VIC, Australia

I`m no expert but it might be your ignition barrel...had it happen on an old VH wagon, start up and everything stops working, even when it was working on accessories, turn the key to start car and it don`t come back properly was the drama...

JAIKAI
Top
 Profile  
 
 
Posted: Tue Jan 02, 2007 11:36 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

If your power mirrors don't operate at least in the ACC/IGN position during this condition, it certainly sounds like an ignition switch/barrel issue.

I'd be removing the plastic covers off the steering column and checking the joiner plugs lower down, and the barrel plug. If you jumper the yellow wire to the black/yellow accessories wire, and your accessories amazingly get power, then this is your likely problem.
BCM/BEM could be an issue, but I'd think it's likely because it may not be getting the necessary power/signals from the IGN barrel.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Tue Jan 02, 2007 4:33 pm 
Stock as a Rock
Offline

Age: 35

Posts: 131

Joined: 6th Nov 2004

Ride: XH Ute

Thanks for the information. That sounds like it could be the issue. Thanks again.
Regards,
Lyle
Top
 Profile  
 
 
Posted: Tue Jan 02, 2007 9:22 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Yeah, best of luck - post back how you went.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 11:05 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names