Fordmods Logo

ED 5.0L wiring harness 


Page 1 of 1 [ 2 posts ] 

 Post subject: ED 5.0L wiring harness
Posted: Wed Jul 23, 2008 12:28 pm 
Smokin em up

Age: 63

Posts: 225

Joined: 9th Nov 2004

Ride: EDV8 Fairmont

Location: perth
WA, Australia

The ED wiring harness on right side of car in engine bay is a real eyesore!
Has anyone hidden the wiring harnesses that run from battery & relays to the firewall?
If so - how & any problems in wiring length?
Can EL 5.0L harness be cut & pasted ( fewer wires ) - I have scrapped the EECIV & am using Motec M800 for engine management- I have a new harness for that, so the engine side of things is not a problem.




1993 ED F/mont 5.0L, Auto, Edelbrock RPM's, CompCam XE276HR, Crane Gold Race 1.7's, Edelbrock Performer, 75mm T/B, MAP, 42lb , GenIII coils, PH4000's , Twin 2.5", Thermos & underspeeds, 3.7 LSD, 2800 stall and MoTec M800, 372fwhp @ 5400rpm & 387 ft-lb @ 4400 rpm.

Posted: Wed Jul 23, 2008 12:30 pm 
Getting Side Ways

Posts: 2425

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Theres no reason you cant run the rest of the wiring under guards. Build your Harness, then use some conduit to protect it.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 15 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 7:25 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names