Fordmods Logo

EF Climate Control Stuffed 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: EF Climate Control Stuffed
Posted: Thu Feb 17, 2005 5:00 pm 
Stock as a Rock
Offline

Age: 37

Posts: 125

Joined: 8th Nov 2004

Gallery: 1 images

Ride: 02 BA XR6T

Location: Adelaide
SA, Australia

Hey all,

the buttons on my EF Climate control are just about shagged. The + (increase) button for the fan and the /\(up) temp controls just dont want to work any more. I have to push the buttons right near the pivot point to make it work. The reduce on each of them works fine, so I'm wondering if it is something to do with the board they are mounted on or something??

What I want to know is:
1) Has anyone else experience this?
2) How much would I be expecting to pay for a new control unit?
3) How much would I be expecting to pay for a second hand control unit from a wrecker?

Thanks

Lee
Top
 Profile  
 
 
Posted: Thu Feb 17, 2005 5:04 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

Contacts may be just dirty, try this thread.

http://www.fordmods.com/phpBB2/viewtopic.php?t=4609

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Thu Feb 17, 2005 7:42 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 686

Joined: 11th Nov 2004

Gallery: 8 images

Ride: EF Fairmont

Location: Perth
WA, Australia

yeah, page two. there are some photos i put up showing how to get into the cc and what to clean..

http://www.fordmods.com/phpBB2/viewtopic.php?t=4914
look at that one to get the dash off.

Use meths on the contacts, much better :D
one u have done all that.. u just gotta learn how to press the buttons.. there is a way of making them work.. kinda sliding from the middle out and holding!
give it a try!

A new one would cost you around $700
a second hand one looking at like $100.. usually has same problem that u have atm (or will do in the near future)

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Feb 18, 2005 8:48 am 
Stock as a Rock
Offline

Age: 37

Posts: 125

Joined: 8th Nov 2004

Gallery: 1 images

Ride: 02 BA XR6T

Location: Adelaide
SA, Australia

Thanks for the help fellas. Might have to give this a try. Need to get the dash out anyway, as the light behind my ODO has gone out

Lee
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 5:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names