Fordmods Logo

EF FAIRMONT CLIMATE CONTROL PROBLEMS 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: EF FAIRMONT CLIMATE CONTROL PROBLEMS
Posted: Sun Apr 27, 2008 7:54 pm 
Fordmods Newbie
Offline

Age: 46

Posts: 4

Joined: 27th Apr 2008

Location: Gloucester
NSW, Australia

My climate control started playing up & was displaying everything as "8"'s, then would shut itself off. Now it doesnt want to turn on. I have checked & has power into the unit but thats as far as it goes. I cant do the diagnosis as it wont turn on. Is there an explanation for this or is it just stuffed??
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 10:37 pm 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

It sounds bad...... i would try pulling power from it for a while and then trying again....

if that fails, I would then be trying a replacement module and see if that fixes it.....

if that fails, I would shout expletives loudly and throw a tantrum.

that will fail, so then I would call a specialist and discuss the problem with them.

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
Posted: Tue Apr 29, 2008 10:16 am 
Fordmods Newbie
Offline

Age: 46

Posts: 4

Joined: 27th Apr 2008

Location: Gloucester
NSW, Australia

Thanks for the advice. It seems that swearing at it & threatening to bury it alive has worked as it is now functioning again. My mate (ex ford mechanic) did a self diagnosis on it before it stopped again & there are no faults showing. But the temp is basically cold up to about 30 degrees & then gets hot after this. I guess this means I should check the blend motor, definatley dont want to pull the dash out. I will give it a week to see if it settles down again. Anyway I should go buy an extra pair of socks & a beanie as it might be a cold winter.
Top
 Profile  
 
 
Posted: Tue Apr 29, 2008 12:18 pm 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

I'd run a self test on it now to see if it spews out any faults......

At least then if it does it next time, you'll know what to look at.

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 6:52 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names