Fordmods Logo

EF transmission LED broken 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: EF transmission LED broken
Posted: Sun Jun 01, 2008 7:34 pm 
Stock as a Rock
Offline

Age: 32

Posts: 110

Joined: 17th May 2008

Gallery: 16 images

Ride: BA

Location: Bendigo
VIC, Australia

The light that illuminates the D , R etc does not work. I'm after a tutorial on replacing it plus any advice anyone has.

Thanks,

Ref

 

_________________

Silver 2003 BA XT - 2 ported 12" Alpine type R subs, 5 by 7 Alpine type R rears, 5 and half inch Alpine splits up front, Alpine head unit.

Blue dome and footwell neons. Debadged and deaerialed. Custom front grill.

Wheels and lowering to come next, then exhaust.

Top
 Profile  
 
 
Posted: Sun Jun 01, 2008 8:15 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2282

Joined: 14th Jan 2005

Gallery: 8 images

Ride: ED Fairmont Ghia & EF XR8

Location: Melbourne
VIC, Australia

im pretty sure its just a park globe as opposed to led's

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 1:20 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names