Fordmods Logo

Electrical problem 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Electrical problem
Posted: Mon Jul 31, 2006 11:38 pm 
Parts Gopher
Offline

Age: 53

Posts: 75

Joined: 3rd May 2006

Ride: ELXR8

Location: Newcastle
NSW, Australia

Hi guys
I have a problem with my brake lights.
When I put my brakes on my park lights & dash lights come on.
Then when I turn my lights on my spoiler brake light stays on.
Any idea what the problem could be.
Thanks Dave.

 

_________________

Tickford A True Legend
Where it all began

Top
 Profile  
 
 
Posted: Mon Jul 31, 2006 11:46 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

you've either got faulty brake light globes
or
you have single fillament ones installed

take them out and replace them with new 'correct' type globes

tail/brake light ones

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Tue Aug 01, 2006 12:02 am 
Getting Side Ways
Offline
User avatar

Age: 53

Posts: 1072

Joined: 6th Jul 2006

Gallery: 13 images

Ride: BA Falcon

Power: 106 rwkw

Location: Craigmore
SA, Australia

this is strange thing I have seen only falcons do, but probably cos I used to work on a few of them.... what has happened is a brake light has blown and melted over to touch the tail light section of the globe...

As Krytox stated, changing you brake light globes will fix it

 

_________________

2003 BA Falcon Egas Taxi Pack - XR Replica
Tpak MKII Build Thread

1984 ZL Fairlane
The Project

Top
 Profile  
 
 
Posted: Tue Aug 01, 2006 12:13 am 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

i had the same thing happen to me when i bought my car.

what krytox said.
check that the brake light globes are duel fillament. that fixed it for me. cost you like $6

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Tue Aug 01, 2006 7:21 pm 
Parts Gopher
Offline

Age: 53

Posts: 75

Joined: 3rd May 2006

Ride: ELXR8

Location: Newcastle
NSW, Australia

Thanks Guys problem solved
I had only recently purchased the clear after market tail lights which came with coloured globes
The red brake globes seemed to put off a orange glow
Bought new red globes problem solved & they glow red.
Thans Dave.

 

_________________

Tickford A True Legend
Where it all began

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 5:30 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names