Fordmods Logo

Help!! LCD odometer not working! 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: Help!! LCD odometer not working!
Posted: Sun Mar 19, 2006 4:00 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1640

Joined: 16th Jun 2005

Gallery: 11 images

Ride: EF Falcon

Location: Driver's Seat
VIC, Australia

Does anyone know how I can fix my odometer? I know this is gonna make me sound like a total noob who doesnt know what he's doing, but whatever...

I pulled out my LCD odometer display coz i wanted to change the color of it (like in one of the tech docs,) but i didn't like it so i pulled it out again to change it back.
but when i went to change it back to the original, one of the rubber things from the LCD display broke off. and now it doesnt display anything.
Am i gonna have to replace the whole LCD thing or is it fixable?

Please help, i'm desperate!!

 

_________________

-------- Falcs --------
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Top
 Profile  
 
 
Posted: Sun Mar 19, 2006 4:31 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

shouldn't matter, as long as you have it in the correct way, make sure the edges are clean and when inserting the plastic holder... make sure it doesn't drop and go in sideways (most likely cause)
Also to make it easier, give it 12volts on the table ur working on, this way you can test it b4 you install it

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Sun Mar 19, 2006 5:08 pm 
Getting Side Ways
Offline
User avatar

Posts: 1552

Joined: 26th Oct 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

hmm ive got the same problem... its just the LCD thing u have to replace but i need to find one (and the only way toget that is getting a cluster and taking it out)

 

_________________

SIGNATURE REMOVED - REFER TO FORUM GUIDELINES!

Top
 Profile  
 
 
Posted: Sun Mar 19, 2006 11:19 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1640

Joined: 16th Jun 2005

Gallery: 11 images

Ride: EF Falcon

Location: Driver's Seat
VIC, Australia

Krytox wrote:
shouldn't matter, as long as you have it in the correct way, make sure the edges are clean and when inserting the plastic holder... make sure it doesn't drop and go in sideways (most likely cause)
Also to make it easier, give it 12volts on the table ur working on, this way you can test it b4 you install it


Thanks heaps!! I'll give it a try tomorrow...


theblackone wrote:
hmm ive got the same problem... its just the LCD thing u have to replace but i need to find one (and the only way toget that is getting a cluster and taking it out)


have you tried what krytox said? I hope I dont have to get a new one aswell.. :?

 

_________________

-------- Falcs --------
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Top
 Profile  
 
 
Posted: Mon Mar 20, 2006 11:32 pm 
Getting Side Ways
Offline
User avatar

Posts: 1552

Joined: 26th Oct 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

yep tried itlike that
i think the lcd is cracked :S

 

_________________

SIGNATURE REMOVED - REFER TO FORUM GUIDELINES!

Top
 Profile  
 
 
Posted: Tue Mar 21, 2006 2:25 am 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

if u havent dropped the LCD or stepped on it or something. then the LCD should work so long as the rubber pieces have contact with the LCD as well as the circuit board. there are "wirings" inside the rubber that transmit the data from the circuit to the LCD. so if they arent in the correct way or dont touch either end then it wont work

hope that gave u some info

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Tue Mar 21, 2006 10:33 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1640

Joined: 16th Jun 2005

Gallery: 11 images

Ride: EF Falcon

Location: Driver's Seat
VIC, Australia

Cool, thanks guys.. I think i should be ok then, coz my LCD's still in good condition. Just need to find time to fix it up.

 

_________________

-------- Falcs --------
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Top
 Profile  
 
 
Posted: Fri Mar 24, 2006 12:12 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1640

Joined: 16th Jun 2005

Gallery: 11 images

Ride: EF Falcon

Location: Driver's Seat
VIC, Australia

Woo hoo!!!
Fixed it!! Giggidy giggidy giggidy gooo!!

Thanks for the info guys, really helped! :D

 

_________________

-------- Falcs --------
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Top
 Profile  
 
 
Posted: Fri Mar 24, 2006 9:43 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

well done mate. good to hear u got it back to running order.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 5:15 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names