Fordmods Logo

Help - my 1992 EBI falcon keeps driving (same speed) 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Help - my 1992 EBI falcon keeps driving (same speed)
Posted: Sat Mar 12, 2005 12:56 pm 
Fordmods Newbie
Offline
User avatar

Age: 49

Posts: 9

Joined: 12th Mar 2005

Gallery: 2 images

Ride: VT clubsport

Location: melbourne
VIC, Australia

Hi, I dont know whats wrong - it feels like a cruise control but when I hit the brakes it still is pushing to go forward but eventualy the revs drop.... wether I am traveling at 40, 60 or 100 klms/h it sticks & holds the speed most of the time hot or cold engine ??? - so if I am coming to a halt I have to put it in neutral to get it to remember that I am not accerating, then it seems to reset until I accelerate again?

Please HELP! :? :?

Marty

 

_________________

No Pain No Gain }}----:::::>>>>

Top
 Profile  
 
 
Posted: Sat Mar 12, 2005 2:50 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1434

Joined: 5th Nov 2004

Gallery: 15 images

Ride: ALTED XR6 - ALTED EA - EF TAXI

Location: Sunshine Coast QLD
QLD, Australia

Is it an auto? .. if so, sounds like your torque convertor could be locking up, and not letting go ..

reco box time .
Top
 Profile  
 
 
Posted: Sat Mar 12, 2005 9:58 pm 
Fordmods Newbie
Offline
User avatar

Age: 49

Posts: 9

Joined: 12th Mar 2005

Gallery: 2 images

Ride: VT clubsport

Location: melbourne
VIC, Australia

Yep - she's a 4spd auto - car only done 180 clicks, just shocked that this would suddenly happen :oops:

 

_________________

No Pain No Gain }}----:::::>>>>

Top
 Profile  
 
 
Posted: Sun Mar 13, 2005 5:21 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

If you are actually using cruise control and this happens, your brake light circuit is probably out (globe or pedal switch).

It sounds like a stuck throttle linkage or cable to me. Check for kinks or damage to the cable and give the linkages at the throttle body a good squirt of WD40. Otherwise, this sounds dangerous. If you can't handle mechanical work, get it to a mechanic quickly!

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
Posted: Tue Mar 15, 2005 12:30 am 
Fordmods Newbie
Offline
User avatar

Age: 49

Posts: 9

Joined: 12th Mar 2005

Gallery: 2 images

Ride: VT clubsport

Location: melbourne
VIC, Australia

I have dowsed it in WD40 but it still seems to happen within the first 10mins of driving - my mechanic cant see me till Thursday .... Idosnt have cruise control but it certainly can feel like it :(

 

_________________

No Pain No Gain }}----:::::>>>>

Top
 Profile  
 
 
Posted: Tue Mar 15, 2005 2:04 am 
Getting Side Ways
Offline
User avatar

Posts: 1043

Joined: 7th Feb 2005

Location: Canberra
ACT, Australia

Sounds like it could be the idle speed controller gone wacky?
Its mounted on the intake at the throttle body.

 

_________________

1993 ED XR6 5speed Polynesian Green. Project car.

1998 EL XR8 Auto Hot Chilli Red. New daily and project

Top
 Profile  
 
 
Posted: Tue Mar 15, 2005 5:18 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

Its it a Centre Point or Multipoint EFI system?

If its a Centre Point, they are renowned for killing the TPS and then doing what you are experiencing. New TPS is abot $120 and you could fit it yourself.

My work mate has a loooong experience with TPS's on his CFI and this problem, to the point where I did a multipoint conversion for him.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:47 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names