Fordmods Logo

Help my cruise control has gone phsyco??? 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: Help my cruise control has gone phsyco???
Posted: Sun Nov 21, 2004 11:34 am 
Tyre Shredder
Offline
User avatar

Age: 35

Posts: 362

Joined: 9th Nov 2004

Gallery: 6 images

Ride: au2

Location: Redbank Plains
QLD, Australia

I went to use my cruise control a couple of weeks ago and it wouldn't work. I tried everything i could think of to get it to work, i even hit the control on the steering wheel a few times which broke it so i had to get a new one. After replacing it, it started working again. Then a couple of days later it stopped again. It now only works when it wants to, ....... I think the best day for it is sundays and wednesdays but i don't know??????



CAN ANYONE HELP ME!!!!!!!!!!!!!!!!!!!!! :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil:

 

_________________

"Press 'any key', where the hell is the any key!!!!!!!!!!!"

Top
 Profile  
 
 
Posted: Sun Nov 21, 2004 12:41 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2976

Joined: 5th Nov 2004

Ride: BF Typhoon

Location: Melbourne
VIC, Australia

1st of all, as good as it feels to hit things, dont hit ya car, its costly and makes you feel worse after you do damge to her.
2nd, whats the prob exactly, does it turn on, does it set, will it not hold speed accurately?
3rd, try pulling the switches out n re installing them again, maybe its the connection?
Im guessing now, let us know some more info. :wink:

 

_________________

BF Typhoon, Dejavu - 6sp Auto, Leather, Sunroof, 19"s, Electric Pedals, Tint, FPV Sports Wheel, FPV Mats.

Top
 Profile  
 
 
Posted: Sun Nov 21, 2004 1:21 pm 
Tyre Shredder
Offline
User avatar

Age: 35

Posts: 362

Joined: 9th Nov 2004

Gallery: 6 images

Ride: au2

Location: Redbank Plains
QLD, Australia

i can turn it on but it wont set..... though when it does set it works fine.

 

_________________

"Press 'any key', where the hell is the any key!!!!!!!!!!!"

Top
 Profile  
 
 
Posted: Sun Nov 21, 2004 1:48 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2976

Joined: 5th Nov 2004

Ride: BF Typhoon

Location: Melbourne
VIC, Australia

Check to see if your brake lights are working normal all the time.
I had this prob and ignored it for a lill while then i couldnt use my cruise anymore - it was going on but couldnt set a speed on it, turned out to be brake switch was dieing then completely died on me! :evil:

 

_________________

BF Typhoon, Dejavu - 6sp Auto, Leather, Sunroof, 19"s, Electric Pedals, Tint, FPV Sports Wheel, FPV Mats.

Top
 Profile  
 
 
Posted: Sun Nov 21, 2004 2:12 pm 
Getting Side Ways
Offline

Age: 31

Posts: 3772

Joined: 5th Nov 2004

Gallery: 33 images

Ride: EL Fairmont Ghia

Location: Hobart
TAS, Australia

sometimes the buttons cease up as well with dirt u might wanna check that
Top
 Profile  
 
 
 Post subject: Re: Help my cruise control has gone phsyco???
Posted: Sun Nov 21, 2004 7:13 pm 
Parts Gopher
Offline
User avatar

Age: 55

Posts: 95

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Giha

Location: Redcliffe
QLD, Australia

Screamer wrote:
i even hit the control on the steering wheel a few times which broke it so i had to get a new one. After replacing it, ......


Rapier wrote:
sometimes the buttons cease up as well with dirt u might wanna check that


Sorry Rapier but it looks like Screamer has already looked after this. Unless of course Screamer, the new was 2nd hand.

If the cruise is showing "on" the dash then the switchs are working.
So 1 down lets go through the rest.


As Daniel pointed out, check the brake lights. Could be the brake switch adjustment or just plain effed or in my case see the next line.

Check the vacum hose. (mine fell off the brake switch, twice. Slippery little sucker. Pun not intended)

Make certain the cable is adjusted properly

Sunday & Wednesday - You didn't say which days you drive the car, could be something to do with it. :) (sorry, to many Boubons and paint fumes)

Is the vacum pump working? Thumb over the vacum pipe off the brake switch will help here (get someone else to do this as at 50k+ you should keep your eye's on the road.)

Is the vacum servo on the end of the cable working? The entry for the vacum hose is a angle piece on my EA and was loose. Luv that silastic and duct tape.

Disclaimer - My thanx's to those who helped recently when I also had CC malfunction.

Screamer wrote:
CAN ANYONE HELP ME!!!!!!!!!!!!!!!!!!!!! :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil:


You left your self open here. Bring it on guy's

 

_________________

Weapon - EA Fairmont Ghia - Pedders lows, Neothane,

From another biker - Scott, you rode hard, lived hard, loved hard, Thanx's for your advice and RIP

Top
 Profile  
 
 
Posted: Mon Nov 22, 2004 2:56 am 
Technical Contributor
Offline

Age: 31

Posts: 6047

Joined: 12th Nov 2004

Ride: Ford Ef Futura

Location: Perth
WA, Australia

i notice sometimes my cruise control wont set the first or second time i press the button but it doesnt sound as severe as your problem. mine sets its just a matter of doing it properly.

i first thought the wiring might be loose or rubbing agaisnt the steering column. i didnt know the dirt affected it.
Top
 Profile  
 
 
Posted: Mon Nov 22, 2004 8:07 am 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Which falcon is this?

If you have an EA/B/D, theres a good chance the little pins in the steering column that transfer the electrical signal have worn down, and you arent getting good contact.

Two things work : 1 : You cant just tighten the steering wheel up loosely, and 2 : Get new pins : Theyre not real expensive.

Doesnt happen on EF/L/AU etc as these had a clockspring to support the airbag.

Nigel
Top
 Profile  
 
 
Posted: Mon Nov 22, 2004 1:24 pm 
Tyre Shredder
Offline
User avatar

Age: 35

Posts: 362

Joined: 9th Nov 2004

Gallery: 6 images

Ride: au2

Location: Redbank Plains
QLD, Australia

no its an au series 2 ....thanks guys i'll check all that stuff out this weekend . Cheers :D

 

_________________

"Press 'any key', where the hell is the any key!!!!!!!!!!!"

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:45 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names