Fordmods Logo

Instrument Display faulty 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Instrument Display faulty
Posted: Sat Apr 22, 2006 8:18 pm 
Oompa Loompa
Offline

Age: 62

Posts: 20

Joined: 2nd May 2005

Ride: EF XR6

Location: Nelspruit, South Africa
Oustide Australia

I have a problem with all the displays on the intrumentation panel. The milage and trip counters as well as the warning lights does not work.
I have checked the fuses and all seems ok. i donot have a service manual- can some one please guide me throught this. thank you. 1997 EF :?: XR6

 

_________________

V8 and 6 cylinder performance enthusiast in South Africa.

Top
 Profile  
 
 
Posted: Sat Apr 22, 2006 8:23 pm 
Getting Side Ways
Offline

Posts: 4967

Joined: 22nd Nov 2004

Location: FAR FAR AWAY LAND
QLD, Australia

Have they always not worked, or just stopped working?

 

_________________

Image

Top
 Profile  
 
 
Posted: Sat Apr 22, 2006 11:27 pm 
Oompa Loompa
Offline

Age: 62

Posts: 20

Joined: 2nd May 2005

Ride: EF XR6

Location: Nelspruit, South Africa
Oustide Australia

noisuf wrote:
Have they always not worked, or just stopped working?

 

_________________

V8 and 6 cylinder performance enthusiast in South Africa.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: Spinb, Yahoo [Bot] and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 9:24 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names