Fordmods Logo

Interior lights and rear demister not working. 

 

Page 2 of 2 [ 19 posts ] Go to page Previous  1, 2

 
Posted: Wed Apr 27, 2005 2:36 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 686

Joined: 11th Nov 2004

Gallery: 8 images

Ride: EF Fairmont

Location: Perth
WA, Australia

this is how to test if ur bem aint working.. thanks to xyphiod.. :D:D

Xyphoid wrote:
Laximah wrote:
i have a feeling its the BEM?
mind explaining what, where and how much a BEM is ??

edit- park lamps DO light up, but the gear lights (PRND321) DONT light up when everythign is in unplugged?

whats this mean ?


The BEM is the Body Electronics Module.
When you pulled apart the dash, the connector below the climate control, that plugs into a plug with a green surround.... Thats the BEM.

If your BEM is fried, You will want a High Series EF BEM. (Green Colour).
Basically a BEM from a EF - EFII Fairmont, EF - EFII Fairmont Ghia, NF Fairlane, DF LTD.
Price will vary, but basically a High Series BEM will only fit the above vehicles. To make them work with other models is a right royal pain in the butt.... So remind the wrecker of this, and use it as a bargaining tool.

As for the PRND321 not lighting up, but the Park lights working.....
Its probably just a blown bulb, and doesnt mean anything if the ciggy lighter bulb is working.

Check to see if the BEM is grounding the Negative Illumination Line.
Do this by checking the Dark Blue / Red Stripe Line on the Trip Computer Plug with a multimeter, with the Park lights turned ON

Image

If you dont have a multimeter, then try GROUNDING this line (I.E. Feed it (-) voltage) with the lights on, and the instrument cluster plugged in.
If the Instrument cluster Illuminates, then Your BEM is Cactus !

(Make sure you do this with KNOWN WORKING BULBS IN YOUR CLUSTER !)

Let us know how it goes


if it is the bem then time to get a new one!

[quote="Xyphoid"]I got one a while ago to screw around with... Cost me $20 or so...
That was an EF Green) Fairmont Bem.

I may as well post up info on removing and replacing while im here.

Removal :
Remove the radio surround,
Remove the Instrument cluster surround,
Unplug the upper BEM Plug (The tab on the connector is on the passenger side of the plug, press it down, and pull on the plug to remove)
Underneath the dash, the BEM has (2 for High, 1 for Mid and Low Series) plugs. Unplug these using brute force Lol ! (They are plugged in to the green module, located right where your knee would sit if you have your seat moved all the way forward. its above the Footrest....
On each side of the BEM plug, there are 2 screws. Remove these.
The BEM finally has a clip holding on to the plastic part of the dash.
Simply jiggle the BEM, pulling it downwards, and it should become unstuck, and come out....

It will take you about 10 minutes to remove the BEM, mind you your car will be undrivable when you do.

To insert is the exact opposite proceedure.
Ohhh, and dont forget to do the Smartlock relearn proceedure... Which is
1) Plug in all BEM plugs.
2) make sure all the BEM features work for you (Interior lights, cluster Illumination, etc, etc)
3) Insert your key in the ignition, and turn to the ON position (Dont start the car)
4) Wind down drivers window (See step 9)
5) Grab a beer, or any other alcamoholic beverage...
6) Drink Beer, or any other alcamoholic beverage...
7) Grab another Beer......
8) conitnue with steps 4) 5) and 6) until 30-45 minutes have elapsed
9) the door locks will cycle (Thats why I said open your window, incase the car locks you out !)
10) Start your Engine !
11) Do a celebratory Burn out on your neighbo

 

_________________

Image

Top
 Profile  
 
 
Posted: Wed Apr 27, 2005 3:25 pm 
Tyre Shredder
Offline
User avatar

Age: 37

Posts: 362

Joined: 5th Nov 2004

Ride: EL Ghia

Location: Melbourne
VIC, Australia

Cheers.

I'll do some investigation tonight, but I'm thinking 'replace BEM' is looking pretty likely

 

_________________

Two hands and one mouth. Now that's a drinnking problem!

Top
 Profile  
 
 
Posted: Thu Apr 28, 2005 2:17 pm 
Tyre Shredder
Offline
User avatar

Age: 37

Posts: 362

Joined: 5th Nov 2004

Ride: EL Ghia

Location: Melbourne
VIC, Australia

Well as it turns out, Demister problem was caused but the demister button not being plugged in firmly enough. Nice 'n easy.

The interior light issue is BEM related, all works fine with another BEM in there. Pulled it apart and vic inspected and redid some of the joins, but to no avail. So now it's time to chase down another BEM.

Thanks to Adrian and Vic for their time and effort helping me trouble shot these annoying problems.

 

_________________

Two hands and one mouth. Now that's a drinnking problem!

Top
 Profile  
 
 
Posted: Thu Apr 28, 2005 2:50 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 686

Joined: 11th Nov 2004

Gallery: 8 images

Ride: EF Fairmont

Location: Perth
WA, Australia

exactely how i did my BEM..
glad u sorted it all out !

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 19 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 5:56 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names