Fordmods Logo

Odometer on EF doesn't light up, easy fix? 

 

Page 2 of 2 [ 20 posts ] Go to page Previous  1, 2

 
Posted: Sat Mar 04, 2006 1:50 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 9

Joined: 16th Mar 2005

Ride: 1994 EF Futura

Location: Geelong
VIC, Australia

Thanks a lot for that, picked up a globe from AutoPro for $3, and just put it in today :)

Now, to do the stereo :D
Top
 Profile  
 
 
Posted: Mon Mar 20, 2006 10:06 pm 
Oompa Loompa
Offline

Age: 31

Posts: 45

Joined: 2nd Oct 2005

Gallery: 2 images

Ride: EL Fairmont

Location: Salt Ash NSW
NSW, Australia

Gaz wrote:
the dash is 6 lights, the odo is a seperate light.. mine was blown the ucnt cost be about 4 bucks :shock:

its down the bottom middle, shouldnt be to hard to figure out


rofl, i just used the light from the demister. no great loss there.
Top
 Profile  
 
 
Posted: Tue Mar 21, 2006 12:14 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1640

Joined: 16th Jun 2005

Gallery: 11 images

Ride: EF Falcon

Location: Driver's Seat
VIC, Australia

dazza2924 wrote:
Lol yeah blue mod modification!

But also when i did mine i accidentally stuffed up the rubber connector things on the side of the enclosure for the Odometer, it may be that i dunno, though it sounds like it might save ya $15 ya never know........


Hey dazza.. the same thing just happened to me a few days ago... did u manage to fix it? or did you have to replace the LCD?

 

_________________

-------- Falcs --------
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Top
 Profile  
 
 
Posted: Tue Mar 21, 2006 7:38 am 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1339

Joined: 7th Nov 2004

Gallery: 3 images

Ride: FGX G6ET

Location: Worrigee
NSW, Australia

The "rubber connector things" are what transfer the signal frfom the PCB to the LCD...they need to be in place properly or the display wont work..just put them back in and all should work again...
Top
 Profile  
 
 
Posted: Tue Mar 21, 2006 10:35 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1640

Joined: 16th Jun 2005

Gallery: 11 images

Ride: EF Falcon

Location: Driver's Seat
VIC, Australia

Sweet, mine should still work then..
Ha, i just got my question answered in two different topics.

 

_________________

-------- Falcs --------
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 20 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 12:18 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names