Fordmods Logo

Realy Bad Speedo Prob Need Help ASAP 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Realy Bad Speedo Prob Need Help ASAP
Posted: Wed Dec 09, 2009 10:31 pm 
Smokin em up
Offline
User avatar

Age: 25

Posts: 278

Joined: 9th Dec 2009

Gallery: 2 images

Ride: Lookin for a EB or ED fairmont

Location: adelaide
SA, Australia

Hey All I just Joined up today and Need some Expert Advice

Well, I got a EBII Fairmont and it's got this realy bad Speedo Problem. It works Fine in
reverse but when i go in forward gears ECT. 1,2,3,D It comes up 0. And when I drive it hard and strong and rev the F**k out of it it sometimes works.

Any ideas please becuase i took it to rebel ford and they have no clue. Chears

 

_________________

Car got Crushed
R.I.P EB Fairmont 05/06/2010

Top
 Profile  
 
 
 Post subject: Re: Realy Bad Speedo Prob Need Help ASAP
Posted: Wed Dec 09, 2009 11:21 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

hi, welcome to fordmods..
have u tried another speedo sender unit? even just check the connection, pull it apart and spray some crc or wd spray on the terminals. anyway theyre cheap from upi etc.
look for one that doesnt have trans fluid on the wiring
Top
 Profile  
 
 
 Post subject: Re: Realy Bad Speedo Prob Need Help ASAP
Posted: Wed Dec 09, 2009 11:57 pm 
Smokin em up
Offline
User avatar

Age: 25

Posts: 278

Joined: 9th Dec 2009

Gallery: 2 images

Ride: Lookin for a EB or ED fairmont

Location: adelaide
SA, Australia

Being 17 i have my limits, But yes i replaced the speedo sensor down in the G'box and replaced the cluster with a mid-series and that didn't even pop up a light.BTW it's a digital one

 

_________________

Car got Crushed
R.I.P EB Fairmont 05/06/2010

Top
 Profile  
 
 
 Post subject: Re: Realy Bad Speedo Prob Need Help ASAP
Posted: Sat Dec 12, 2009 3:19 pm 
Smokin em up
Offline
User avatar

Age: 25

Posts: 278

Joined: 9th Dec 2009

Gallery: 2 images

Ride: Lookin for a EB or ED fairmont

Location: adelaide
SA, Australia

Hay Me again. Does any1 know how to downgrade clusters because as i said before
i repaced my high series with a XR mid series and not a single thing worked so i had to put
the digital one back in.

 

_________________

Car got Crushed
R.I.P EB Fairmont 05/06/2010

Top
 Profile  
 
 
 Post subject: Re: Realy Bad Speedo Prob Need Help ASAP
Posted: Tue Dec 15, 2009 10:30 pm 
Oompa Loompa
Offline

Age: 55

Posts: 31

Joined: 17th Sep 2008

Location: Wagga
NSW, Australia

More info here documents.php?d=45

Reading the EF-EL section may be of some value as you want to downgrade documents.php?d=14
Top
 Profile  
 
 
 Post subject: Re: Realy Bad Speedo Prob Need Help ASAP
Posted: Thu Dec 24, 2009 8:44 pm 
Smokin em up
Offline
User avatar

Age: 25

Posts: 278

Joined: 9th Dec 2009

Gallery: 2 images

Ride: Lookin for a EB or ED fairmont

Location: adelaide
SA, Australia

Hay Finnaly found the proplemo.It was the speedo gear senser thing in the F***ing G'box i took it to ford and they got it sorted out in 30 hours (25 1/2 hours for part from melbo :roll: ) $350 later and i was goin great guns. So if u got that prob u've grinded the gear out

And thanks for all the help guys cos that could've lost me my licence if cops pulled me up and found out it was faulty

 

_________________

Car got Crushed
R.I.P EB Fairmont 05/06/2010

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:45 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names