Fordmods Logo

Smoke from A/C air vents 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Smoke from A/C air vents
Posted: Fri Dec 31, 2004 10:36 pm 
Stock as a Rock
Offline

Posts: 197

Joined: 8th Nov 2004

Ride: FG-XR6 EL EA '24 Dodge

Location: Tamworth
NSW, Australia

Hi All

On a recent trip the air conditioner in my EL seemed to be getting less and less effective then smoke started to come out of the vents.
This stopped when when everything was turned off and was Ok with just the fan on. but smoked up again with the air on.

Its probbably a heap of leaves stuck in the evaporator.

How do I clean it out ?

Somebody posted a method of fixing this In fordmods 1 if I recall but I can't get the search function to work.

 

_________________

As Sigfried once said "Nein Nein Ninty Nine"

Top
 Profile  
 
 
Posted: Sat Jan 01, 2005 4:32 am 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Smoke sounds a lot like a Gas Leak....
... or a water leak that you dont know about. I had same and it was a heater core.
Top
 Profile  
 
 
Posted: Sat Jan 01, 2005 6:26 am 
Getting Side Ways
Offline

Age: 34

Posts: 419

Joined: 6th Nov 2004

Location: canberra
ACT, Australia

it would have to be a big leak to be the a/c gas. and if it was it would smoke u out of ur car.

leaves on the evaporator wouldnt burn as its cold. maybe on the blower motor but i doubt it would burn.

what did the smoke smell like. seems a bit odd.
Top
 Profile  
 
 
Posted: Sat Jan 01, 2005 8:20 am 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

how sure are u that its smoke and not condensation in the air coming out? there isnt enough gas in the system to come out enough for u to describe as "smoke" for very long
Top
 Profile  
 
 
Posted: Sat Jan 01, 2005 2:02 pm 
Stock as a Rock
Offline

Posts: 197

Joined: 8th Nov 2004

Ride: FG-XR6 EL EA '24 Dodge

Location: Tamworth
NSW, Australia

Definitely smoke not gas or vapour. Burning smell.

After the first time it started and having been turned off for 5 or 10 minutes it only came through again after 10 to 15 mins or so.

I'm sure someone posted the same problem in Fordmods 1
Not sure what the remedy was. Something to do with the blower fan I guess.

 

_________________

As Sigfried once said "Nein Nein Ninty Nine"

Top
 Profile  
 
 
Posted: Sat Jan 01, 2005 9:54 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 411

Joined: 28th Dec 2004

Gallery: 5 images

Ride: Falcon BA XT 2005

Location: Melbourne
VIC, Australia

my EB did a similar thing a few months ago, caused by leaves burning on the heater coils. if its the same as my car (prob pretty similar i'd think) u take the glove box out and underneath and behind it is a little vent u can push open upwards with ur hand. prob best to use a straightened coat hanger or something to get all that sh*t out. best also to take out the heater unit and make sure all the coils are free of stuff. if they're burned black ur prob best to replace them.

 

_________________

Clowns are evil and must be killed.

Top
 Profile  
 
 
Posted: Mon Jan 03, 2005 5:05 pm 
Stock as a Rock
Offline

Posts: 197

Joined: 8th Nov 2004

Ride: FG-XR6 EL EA '24 Dodge

Location: Tamworth
NSW, Australia

Isn't there some resistors or something for the blower fan speed control sitting in the air stream that catch debis and need to be cleaned out?
I need to know how to go about doing the cleaning out part.

 

_________________

As Sigfried once said "Nein Nein Ninty Nine"

Top
 Profile  
 
 
Posted: Mon Jan 03, 2005 10:20 pm 
Getting Side Ways
Offline
User avatar

Posts: 882

Joined: 5th Nov 2004

Gallery: 2 images

Ride: In Transition

Location: Sydney
NSW, Australia

Sounds like you need a re-gas
similar problem, it aircon was hopless them smoke came outta the vents and went away

 

_________________

Image
Member Since FM 1

Top
 Profile  
 
 
Posted: Tue Jan 04, 2005 2:45 am 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 411

Joined: 28th Dec 2004

Gallery: 5 images

Ride: Falcon BA XT 2005

Location: Melbourne
VIC, Australia

yeah mine filled the whole car up with smoke and smelled like a bushfire coz all the leaves were on fire, but if urs wasnt that bad then u prob just need re-gassing.

 

_________________

Clowns are evil and must be killed.

Top
 Profile  
 
 
Posted: Tue Jan 04, 2005 3:30 pm 
Stock as a Rock
Offline

Posts: 197

Joined: 8th Nov 2004

Ride: FG-XR6 EL EA '24 Dodge

Location: Tamworth
NSW, Australia

Could have caught fire if I had let it go but I turned it off.
If it was a gas leak then why did it take 10 minutes to smoke up again the second time?

 

_________________

As Sigfried once said "Nein Nein Ninty Nine"

Top
 Profile  
 
 
Posted: Thu Jan 13, 2005 3:21 pm 
Stock as a Rock
Offline

Posts: 197

Joined: 8th Nov 2004

Ride: FG-XR6 EL EA '24 Dodge

Location: Tamworth
NSW, Australia

Clened out the heater/evaporator unit where the circulating fan resistor block is located and got a truck load of leaves out, one of which had obviously been touching against the resistors and had started to smolder thus causing the smoke.

 

_________________

As Sigfried once said "Nein Nein Ninty Nine"

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: Google [Bot], gossdw and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 12:17 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names