Fordmods Logo

Trip computer LCD 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: Trip computer LCD
Posted: Wed Sep 13, 2006 8:25 am 
Parts Gopher
Offline
User avatar

Age: 32

Posts: 98

Joined: 17th Feb 2005

Ride: 05 BA MKII XR8, 95 EF gli Wagon

Location: Gosford
NSW, Australia

Hi All,

I have a trip computer sitting here but the rubber blocks that should be attached to the lcd are not anymore so it wont display anything.

Is there a way to re attach them? or do I have to get a new one?

cheers
Bucko

 

_________________

Image

Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 8:50 am 
Technical Contributor
Offline

Age: 31

Posts: 6047

Joined: 12th Nov 2004

Ride: Ford Ef Futura

Location: Perth
WA, Australia

I broke one of mine off too, just stand it up when you are reassembling the trip computer, worked for me.
Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 10:08 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2550

Joined: 28th Jun 2005

Gallery: 13 images

Ride: EF 5 Speed, XH Uterus :P

Location: Hobart
TAS, Australia

i thought they were meant to come apart when i had mine in pieces....

 

_________________

Maloo - Holden's word for ugly.

Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 1:19 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 529

Joined: 23rd Aug 2006

Ride: 2000 AU Fairmont

Location: Perth
WA, Australia

happened to mine aswell, stick the rubber legs back in the slots and the lcd screen around the RIGHT way (there are 3 coloured stripes on one side indicating which way its supposed to go) then put the black bracket surround thingy that clips on the top back on and screw it down TIGHT.

 

_________________

Image

Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 3:37 pm 
Parts Gopher
Offline
User avatar

Age: 32

Posts: 98

Joined: 17th Feb 2005

Ride: 05 BA MKII XR8, 95 EF gli Wagon

Location: Gosford
NSW, Australia

Thanks all

Ill pull it apart again tonight after work and make sure everything is around the right way.

Bucko

 

_________________

Image

Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 6:52 pm 
Technical Contributor
Offline

Age: 31

Posts: 6047

Joined: 12th Nov 2004

Ride: Ford Ef Futura

Location: Perth
WA, Australia

Razor7107 wrote:
happened to mine aswell, stick the rubber legs back in the slots and the lcd screen around the RIGHT way (there are 3 coloured stripes on one side indicating which way its supposed to go) then put the black bracket surround thingy that clips on the top back on and screw it down TIGHT.


LOL I never noticed those 3 stripes. I lost count the amount of times I put it and the cluster LCD back together upside down.
Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 6:52 pm 
Technical Contributor
Offline

Age: 31

Posts: 6047

Joined: 12th Nov 2004

Ride: Ford Ef Futura

Location: Perth
WA, Australia

Razor7107 wrote:
happened to mine aswell, stick the rubber legs back in the slots and the lcd screen around the RIGHT way (there are 3 coloured stripes on one side indicating which way its supposed to go) then put the black bracket surround thingy that clips on the top back on and screw it down TIGHT.


LOL I never noticed those 3 stripes. I lost count the amount of times I put it and the cluster LCD back together upside down.
Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 8:43 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4946

Joined: 15th Nov 2004

Gallery: 2 images

Ride: Trik'd up EFII XR6

Location: Perth
WA, Australia

twirqurky wrote:
Razor7107 wrote:
happened to mine aswell, stick the rubber legs back in the slots and the lcd screen around the RIGHT way (there are 3 coloured stripes on one side indicating which way its supposed to go) then put the black bracket surround thingy that clips on the top back on and screw it down TIGHT.


LOL I never noticed those 3 stripes. I lost count the amount of times I put it and the cluster LCD back together upside down.


heheh same lol....itd be a big count lol which reminds me i gotta take it out again cause i did it quick n doddgy last time lol and dont display properly lol...to check my kms in full i gotta press on it hehehe :P

 

_________________

For Sale: 25 Farad Rockford Fosgate Competition Series Carbon Cap, more to come - pm me if interested

Top
 Profile  
 
 
Posted: Wed Sep 13, 2006 9:22 pm 
Tyre Shredder
Offline

Age: 29

Posts: 313

Joined: 9th Jan 2006

Ride: EF2 Fairmont Ghia

Location: Eltham
VIC, Australia

:| lol

 

_________________

Cobra Motorsports

1996 EF2 Fairmont Ghia For Sale

Top
 Profile  
 
 
Posted: Thu Sep 14, 2006 8:10 pm 
Parts Gopher
Offline
User avatar

Age: 32

Posts: 98

Joined: 17th Feb 2005

Ride: 05 BA MKII XR8, 95 EF gli Wagon

Location: Gosford
NSW, Australia

ok now i have a new problem, after i got the lcd working again it shows the clock but if i press any button on it the lcd goes blank.

anyone know the cause or how to fix it?

or have i stuffed my trip computer?


Bucko

 

_________________

Image

Top
 Profile  
 
 
Posted: Thu Sep 14, 2006 8:26 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 967

Joined: 8th Nov 2004

Gallery: 7 images

Ride: TE50

Location: Brisvegas
QLD, Australia

was it working before you pulled it apart? if its an add on you may have wired it incorrectly

 

_________________

Formerly SpuDEF

Top
 Profile  
 
 
Posted: Thu Sep 14, 2006 10:27 pm 
Parts Gopher
Offline
User avatar

Age: 32

Posts: 98

Joined: 17th Feb 2005

Ride: 05 BA MKII XR8, 95 EF gli Wagon

Location: Gosford
NSW, Australia

it was working when i first put it in, then the lcd stoped working thats why i pulled it apart.

yes it is an addon, i will re check the wiring on the weekend, but it was working before.

Bucko

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 12:05 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names